ramips: add support for WR8305RT board
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 12 Jul 2014 06:54:03 +0000 (06:54 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 12 Jul 2014 06:54:03 +0000 (06:54 +0000)
Signed-off-by: Jorge Vargas <jorge.vargas@sosvia.com>
Signed-off-by: John Crispin <blogic@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41584 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
target/linux/ramips/base-files/etc/uci-defaults/01_leds
target/linux/ramips/base-files/etc/uci-defaults/02_network
target/linux/ramips/base-files/lib/preinit/06_set_iface_mac
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/WR8305RT.dts [new file with mode: 0644]
target/linux/ramips/image/Makefile

index 14d630e..908547e 100755 (executable)
@@ -152,6 +152,9 @@ get_status_led() {
        wr512-3gn)
                status_led="wr512:green:wps"
                ;;
+       wr8305rt)
+               status_led="wr8305rt:sys"
+               ;;
        wnce2001)
                status_led="netgear:green:power"
                ;;
index b56fb63..e958899 100644 (file)
@@ -120,6 +120,7 @@ case "$FIRMWARE" in
        wnce2001 | \
        wr512-3gn | \
        wr6202 | \
+       wr8305rt | \
        wrtnode | \
        mzk-w300nh2 | \
        ur-326n4g | \
index 00b6040..19ec4f5 100755 (executable)
@@ -186,6 +186,11 @@ case $board in
                set_wifi_led "zbtlink:blue:air"
                set_usb_led "zbtlink:blue:usb"
                ;;
+       wr8305rt)
+               ucidef_set_led_default "power" "power" "wr8305rt:sys" "1"
+               set_usb_led "wr8305rt:usb"
+               set_wifi_led "wr8305rt:wifi"
+               ;;
 esac
 
 ucidef_commit_leds
index a14acb6..472ae58 100755 (executable)
@@ -163,6 +163,13 @@ ramips_setup_interfaces()
                ucidef_add_switch_vlan "switch0" "2" "6t"
                ;;
 
+       wr8305rt)
+               ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
+               ucidef_add_switch "switch0" "1" "1"
+               ucidef_add_switch_vlan "switch0" "1" "0 1 2 3 4 6t"
+               ucidef_add_switch_vlan "switch0" "2" "4 6t"
+               ;;
+
        d105 | \
        na930 | \
        omni-emb-hpm|\
@@ -245,6 +252,11 @@ ramips_setup_macs()
                wan_mac=$(macaddr_add "$lan_mac" 1)
                ;;
 
+       wr8305rt)
+               lan_mac=$(mtd_get_mac_binary factory 4)
+               wan_mac=$(macaddr_add "$lan_mac" 1)
+               ;;
+
        *)
                wan_mac=$(macaddr_add "$lan_mac" 1)
                ;;
index 8538c13..2a0a4fd 100644 (file)
@@ -17,7 +17,8 @@ preinit_set_mac_address() {
        w150m | \
        mzk-w300nh2 |\
        wl-330n |\
-       wl-330n3g)
+       wl-330n3g |\
+       wr8305rt)
                mac=$(mtd_get_mac_binary factory 4)
                ifconfig eth0 hw ether $mac 2>/dev/null
                ;;
index 2ae8c9e..b36b53c 100755 (executable)
@@ -310,6 +310,9 @@ ramips_board_detect() {
        *"Zbtlink ZBT-WA05")
                name="zbt-wa05"
                ;;
+       *"ZBT WR8305RT")
+               name="wr8305rt"
+               ;;
        *)
                name="generic"
                ;;
index 805a63f..8ada58b 100755 (executable)
@@ -89,6 +89,7 @@ platform_check_image() {
        ur-336un |\
        wr512-3gn |\
        wmr300 |\
+       wr8305rt |\
        wrtnode |\
        x5 |\
        x8 |\
diff --git a/target/linux/ramips/dts/WR8305RT.dts b/target/linux/ramips/dts/WR8305RT.dts
new file mode 100644 (file)
index 0000000..81653f5
--- /dev/null
@@ -0,0 +1,108 @@
+/dts-v1/;
+
+/include/ "mt7620n.dtsi"
+
+/ {
+       compatible = "wr8305rt", "ralink,mt7620n-soc";
+       model = "ZBT WR8305RT";
+
+       palmbus@10000000 {
+               gpio1: gpio@638 {
+                       status = "okay";
+               };
+               gpio3: gpio@688 {
+                       status = "okay";
+               };
+
+               spi@b00 {
+                       status = "okay";
+
+                       m25p80@0 {
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               compatible = "mx25l6405d";
+                               reg = <0 0>;
+                               linux,modalias = "m25p80", "en25q64";
+                               spi-max-frequency = <10000000>;
+
+                               partition@0 {
+                                       label = "u-boot";
+                                       reg = <0x0 0x30000>;
+                                       read-only;
+                               };
+
+                               partition@30000 {
+                                       label = "u-boot-env";
+                                       reg = <0x30000 0x10000>;
+                                       read-only;
+                               };
+
+                               factory: partition@40000 {
+                                       label = "factory";
+                                       reg = <0x40000 0x10000>;
+                                       read-only;
+                               };
+
+                               partition@50000 {
+                                       label = "firmware";
+                                       reg = <0x50000 0x7b0000>;
+                               };
+                       };
+               };
+       };
+
+       ehci@101c0000 {
+               status = "okay";
+       };
+
+       ohci@101c1000 {
+               status = "okay";
+       };
+
+       ethernet@10100000 {
+               mtd-mac-address = <&factory 0x4>;
+               ralink,port-map = "llllw";
+       };
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       ephy {
+                               ralink,group = "ephy";
+                               ralink,function = "ephy";
+                       };
+                       default {
+                               ralink,group = "i2c", "uartf", "spi refclk", "wled";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+               sys {
+                       label = "wr8305rt:sys";
+                       gpios = <&gpio1 14 1>;
+               };
+               lan {
+                       label = "wr8305rt:usb";
+                       gpios = <&gpio1 15 1>;
+               };
+               wifi {
+                       label = "wr8305rt:wifi";
+                       gpios = <&gpio3 0 1>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 1 1>;
+                       linux,code = <0x198>;
+               };
+       };
+};
+
index e3ba60e..25889ea 100644 (file)
@@ -737,6 +737,7 @@ endif
 
 Image/Build/Profile/WMR300=$(call BuildFirmware/Default8M/$(1),$(1),wmr-300,WMR300)
 Image/Build/Profile/RT-N14U=$(call BuildFirmware/Default8M/$(1),$(1),rt-n14u,RT-N14U)
+Image/Build/Profile/WR8305RT=$(call BuildFirmware/Default8M/$(1),$(1),wr8305rt,WR8305RT)
 Image/Build/Profile/WRTNODE=$(call BuildFirmware/Default16M/$(1),$(1),wrtnode,WRTNODE)
 Image/Build/Profile/ZBT-WA05=$(call BuildFirmware/Default8M/$(1),$(1),zbt-wa05,ZBT-WA05)
 
@@ -744,6 +745,7 @@ ifeq ($(SUBTARGET),mt7620n)
 define Image/Build/Profile/Default
        $(call Image/Build/Profile/WMR300,$(1))
        $(call Image/Build/Profile/RT-N14U,$(1))
+       $(call Image/Build/Profile/WR8305RT,$(1))
        $(call Image/Build/Profile/WRTNODE,$(1))
        $(call Image/Build/Profile/ZBT-WA05,$(1))
 endef