imx6: add canbus support for Ventana boards
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 11 Dec 2013 10:56:11 +0000 (10:56 +0000)
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 11 Dec 2013 10:56:11 +0000 (10:56 +0000)
GW5400, GW5300, and GW5200 have CAN bus option.

Signed-off-by: Tim Harvey <tharvey@gateworks.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39034 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/imx6/files-3.10/arch/arm/boot/dts/imx6dl-gw52xx.dts
target/linux/imx6/files-3.10/arch/arm/boot/dts/imx6dl-gw53xx.dts
target/linux/imx6/files-3.10/arch/arm/boot/dts/imx6q-gw54xx.dts
target/linux/imx6/profiles/120-gateworks.mk

index 400c064..eef42ed 100644 (file)
@@ -18,6 +18,7 @@
 
        /* these are used by bootloader for disabling nodes */
        aliases {
+               can0 = &can1;
                ethernet0 = &fec;
                i2c0 = &i2c1;
                i2c1 = &i2c2;
        status = "okay";
 };
 
+&can1 {
+       pinctrl-names = "default";
+       pinctrl-0 = <&pinctrl_flexcan1_1>;
+       status = "okay";
+};
+
 &fec {
        pinctrl-names = "default";
        pinctrl-0 = <&pinctrl_enet_1>;
index 87f0be2..99d3d4c 100644 (file)
 };
 
 &can1 {
+       pinctrl-names = "default";
+       pinctrl-0 = <&pinctrl_flexcan1_1>;
        status = "okay";
 };
 
index f9cf29a..828fc81 100644 (file)
 };
 
 &can1 {
+       pinctrl-names = "default";
+       pinctrl-0 = <&pinctrl_flexcan1_1>;
        status = "okay";
 };
 
index 830b3b2..9891527 100644 (file)
@@ -10,6 +10,7 @@ define Profile/VENTANA
   PACKAGES:= \
        kmod-thermal-imx kmod-sky2 kmod-usb-chipidea kmod-usb-mxs-phy \
        kmod-sound-soc-imx kmod-sound-soc-imx-sgtl5000 \
+       kmod-can kmod-can-flexcan \
        kobs-ng
 endef