PXA can use EABI, too
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 26 Apr 2008 10:14:55 +0000 (10:14 +0000)
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 26 Apr 2008 10:14:55 +0000 (10:14 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10949 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/pxa/Makefile

index 7bf4c38..d4d326f 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=pxa
-BOARDNAME:=PXA
+BOARDNAME:=Marvell/Intel PXA2xx
 FEATURES:=jffs2 broken
 
 LINUX_VERSION:=2.6.21.7
@@ -16,7 +16,13 @@ LINUX_VERSION:=2.6.21.7
 include $(INCLUDE_DIR)/target.mk
 
 define Target/Description
-       Stub for boards based on intel PXA
+       Build images for PAX2xx systems, eg. Gumstix.
+endef
+
+define Kernel/Configure
+       $(call Kernel/Configure/Default)
+       $(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(LINUX_DIR)/.config
+       $(if $(CONFIG_EABI_SUPPORT),echo '# CONFIG_OABI_COMPAT is not set' >> $(LINUX_DIR)/.config)
 endef
 
 $(eval $(call BuildTarget))