Add hostapd-mini to default images where applicable
authoragb <agb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 2 Jan 2009 05:12:46 +0000 (05:12 +0000)
committeragb <agb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 2 Jan 2009 05:12:46 +0000 (05:12 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13819 3c298f89-4303-0410-b956-a3cf2f4a3e73

19 files changed:
target/linux/adm5120/Makefile
target/linux/adm5120/router_le/profiles/Cellvision.mk
target/linux/adm5120/router_le/profiles/Edimax.mk
target/linux/ar71xx/Makefile
target/linux/atheros/Makefile
target/linux/au1000/Makefile
target/linux/au1000/profiles/InternetBox.mk
target/linux/au1000/profiles/MeshCube.mk
target/linux/brcm-2.4/profiles/120-Atheros.mk
target/linux/brcm47xx/Makefile
target/linux/brcm47xx/profiles/110-None.mk
target/linux/brcm63xx/Makefile
target/linux/ifxmips/Makefile
target/linux/ifxmips/profiles/000-None.mk
target/linux/ixp4xx/generic/profiles/200-NSLU2.mk
target/linux/ixp4xx/generic/profiles/500-USR8200.mk
target/linux/ixp4xx/generic/target.mk
target/linux/rb532/Makefile
target/linux/rdc/Makefile

index 9a601e4..4e63a0f 100644 (file)
@@ -15,11 +15,7 @@ INITRAMFS_EXTRA_FILES:=
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += admswconfig
-DEFAULT_PACKAGES += \
-       kmod-input-core \
-       kmod-input-polldev \
-       kmod-input-gpio-buttons \
-       kmod-button-hotplug
+DEFAULT_PACKAGES += admswconfig hostapd-mini kmod-input-core \
+                   kmod-input-polldev kmod-input-gpio-buttons kmod-button-hotplug
 
 $(eval $(call BuildTarget))
index 9c8356a..9fa1e02 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007,2008 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,6 +8,7 @@
 define Profile/CAS630
        NAME:=Cellvision CAS-630 IP camera (Experimental)
        # TODO: add default packages
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/CAS630/Description
@@ -17,6 +18,7 @@ endef
 define Profile/CAS630W
        NAME:=Cellvision CAS-630W IP camera (Experimental)
        # TODO: add default packages
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/CAS630W/Description
@@ -26,6 +28,7 @@ endef
 define Profile/CAS670
        NAME:=Cellvision CAS-670 IP camera (Experimental)
        # TODO: add default packages
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/CAS670/Description
@@ -35,6 +38,7 @@ endef
 define Profile/CAS670W
        NAME:=Cellvision CAS-670W IP camera (Experimental)
        # TODO: add default packages
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/CAS670W/Description
@@ -44,6 +48,7 @@ endef
 define Profile/CAS700
        NAME:=Cellvision CAS-700 IP camera (Experimental)
        # TODO: add default packages
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/CAS700/Description
@@ -53,6 +58,7 @@ endef
 define Profile/CAS700W
        NAME:=Cellvision CAS-700W IP camera (Experimental)
        # TODO: add default packages
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/CAS700W/Description
@@ -61,7 +67,7 @@ endef
 
 define Profile/CAS771
        NAME:=Cellvision CAS-771 IP camera (Experimental)
-       PACKAGES:=kmod-video-cpia2 kmod-usb-ohci kmod-usb2 kmod-usb-audio
+       PACKAGES:=-hostapd-mini kmod-video-cpia2 kmod-usb-ohci kmod-usb2 kmod-usb-audio
 endef
 
 define Profile/CAS771/Description
@@ -70,7 +76,7 @@ endef
 
 define Profile/CAS771W
        NAME:=Cellvision CAS-771W IP camera (Experimental)
-       PACKAGES:=kmod-video-cpia2 kmod-usb-ohci kmod-usb2 kmod-usb-audio kmod-rt2500-pci
+       PACKAGES:=-hostapd-mini kmod-video-cpia2 kmod-usb-ohci kmod-usb2 kmod-usb-audio kmod-rt2500-pci
 endef
 
 define Profile/CAS771W/Description
@@ -80,6 +86,7 @@ endef
 define Profile/CAS790
        NAME:=Cellvision CAS-790 IP camera (Experimental)
        # TODO: add default packages
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/CAS790/Description
@@ -89,6 +96,7 @@ endef
 define Profile/CAS861
        NAME:=Cellvision CAS-861 IP camera (Experimental)
        # TODO: add default packages
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/CAS861/Description
@@ -106,6 +114,7 @@ endef
 
 define Profile/NFS101U
        NAME:=Cellvision NFS-101U Network File Server (Experimental)
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/NFS101U/Description
@@ -114,6 +123,7 @@ endef
 
 define Profile/NFS101WU
        NAME:=Cellvision NFS-101WU Network File Server (Experimental)
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/NFS101WU/Description
index e4c427f..70b2653 100644 (file)
@@ -7,6 +7,7 @@
 
 define Profile/BR6104K
        NAME:=Edimax BR-6104K (Unofficial)
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/BR6104K/Description
@@ -15,7 +16,7 @@ endef
 
 define Profile/BR6104KP
        NAME:=Edimax BR-6104KP (Unofficial)
-       PACKAGES:=kmod-usb-core kmod-usb-adm5120
+       PACKAGES:=-hostapd-mini kmod-usb-core kmod-usb-adm5120
 endef
 
 define Profile/BR6104KP/Description
@@ -24,6 +25,7 @@ endef
 
 define Profile/BR6104WG
        NAME:=Edimax BR-6104Wg (Unofficial, No WiFi)
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/BR6104WG/Description
@@ -32,6 +34,7 @@ endef
 
 define Profile/BR6114WG
        NAME:=Edimax BR-6114WG (Unofficial, No WiFi)
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/BR6114WG/Description
index fe32e86..4aae711 100644 (file)
@@ -15,7 +15,7 @@ LINUX_VERSION:=2.6.26.8
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += kmod-madwifi
+DEFAULT_PACKAGES += hostapd-mini kmod-madwifi
 
 define Target/Description
        Build firmware images for Atheros AR71xx based boards
index 3399405..4d7c316 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,7 +15,7 @@ LINUX_VERSION:=2.6.26.8
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += kmod-madwifi gpioctl
+DEFAULT_PACKAGES += hostapd-mini kmod-madwifi gpioctl
 
 define Target/Description
        Build firmware images for Atheros SoC boards
index 113f552..ed31eb7 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -14,7 +14,7 @@ FEATURES:=jffs2 usb pci
 LINUX_VERSION:=2.6.27.10
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += yamonenv
+DEFAULT_PACKAGES += hostapd-mini yamonenv
 
 define Target/Description
        Build firmware for AMD Alchemy 1500 boards
index 642f0e2..ee32ddb 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ define Profile/InternetBox
   NAME:=T-Mobile "InternetBox"
   PACKAGES:=kmod-madwifi \
                ldconfig ldd \
-               hostapd hostapd-utils ip tc wpa-supplicant wpa-cli
+               ip tc wpa-supplicant wpa-cli
 endef
 
 define Profile/InternetBox/Description
index 257f8d0..ddfae67 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,8 +9,7 @@ define Profile/MeshCube
   NAME:=MeshCube MTX-1
   PACKAGES:=kmod-madwifi kmod-hostap kmod-hostap-pci kmod-net-prism54 \
        kmod-usb-core kmod-usb-ohci kmod-usb-storage kmod-fs-ext3 kmod-fs-vfat \
-       ldconfig ldd \
-       hostap-utils hostapd hostapd-utils ip tc wpa-supplicant wpa-cli
+       ldconfig ldd hostap-utils ip tc wpa-supplicant wpa-cli
 endef
 
 define Profile/MeshCube/Description
index d721abb..c31f9a0 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,7 +7,7 @@
 
 define Profile/Atheros
   NAME:=Generic, Atheros WiFi
-  PACKAGES:=kmod-madwifi
+  PACKAGES:=hostapd-mini kmod-madwifi
 endef
 
 define Profile/Atheros/Description
index a348236..2481e7f 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -14,7 +14,7 @@ FEATURES:=squashfs usb
 LINUX_VERSION:=2.6.25.20
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += kmod-switch kmod-diag
+DEFAULT_PACKAGES += hostapd-mini kmod-switch kmod-diag
 
 define Target/Description
        Build firmware images for Broadcom based routers
index 2fcfacd..513366d 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,7 +7,7 @@
 
 define Profile/None
   NAME:=No WiFi
-  PACKAGES:=
+  PACKAGES:=-hostapd-mini
 endef
 
 define Profile/None/Description
index c8862f0..eecfd9b 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -14,6 +14,8 @@ LINUX_VERSION:=2.6.27.10
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += hostapd-mini
+
 define Target/Description
        Build firmware images for Broadcom based xDSL/routers
        currently supports BCM6348 and BCM6358 based devices.
index c05f709..e590eee 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,7 +15,7 @@ LINUX_VERSION:=2.6.26.8
 #LINUX_VERSION:=2.6.27.10
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES+=uboot-ifxmips
+DEFAULT_PACKAGES+=uboot-ifxmips hostapd-mini
 
 define Target/Description
        Build firmware images for Infineon Mips Controllers
index 5bfea2f..18c5c0c 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,7 +7,7 @@
 
 define Profile/None
   NAME:=Generic, No WiFi
-  PACKAGES:=
+  PACKAGES:=-hostapd-mini
 endef
 
 define Profile/None/Description
index 17e48a5..596710f 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,7 +7,7 @@
 
 define Profile/NSLU2
   NAME:=Linksys NSLU2
-  PACKAGES:=kmod-scsi-core \
+  PACKAGES:=-hostapd-mini kmod-scsi-core \
        kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-storage \
        kmod-fs-ext2 kmod-fs-ext3
 endef
index 9306f79..2ef0784 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,7 +7,7 @@
 
 define Profile/USR8200
   NAME:=USRobotics USR8200
-  PACKAGES:=kmod-scsi-core \
+  PACKAGES:=-hostapd-mini kmod-scsi-core \
        kmod-usb-core kmod-usb-uhci kmod-usb2 kmod-usb-storage \
        kmod-fs-ext2 kmod-fs-ext3 \
        kmod-ieee1394 kmod-ohci1394 kmod-sbp2
index 21fd5d4..e89cfc4 100644 (file)
@@ -1,5 +1,7 @@
 BOARDNAME:=Generic
 
+DEFAULT_PACKAGES+= hostapd-mini
+
 define Target/Description
        Build firmware images for ixp4xx based boards that boot from internal flash
        (e.g : Linksys NSLU2, ...)
index af5469e..e35b81c 100644 (file)
@@ -14,6 +14,6 @@ FEATURES:=jffs2 pci tgz
 LINUX_VERSION:=2.6.24.7
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += kmod-madwifi
+DEFAULT_PACKAGES += hostapd-mini kmod-madwifi
 
 $(eval $(call BuildTarget))
index 86265c3..55600f9 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,6 +15,8 @@ LINUX_VERSION:=2.6.24.7
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += hostapd-mini
+
 define Target/Description
         Build firmware images for RDC321x based routers
         (e.g. Airlink101 AR525W, Linksys WRT54GR, Sitecom WL-153)