curl: add config option for NTLM support
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 17 Apr 2016 12:51:41 +0000 (12:51 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 17 Apr 2016 12:51:41 +0000 (12:51 +0000)
Signed-off-by: Dirk Feytons <dirk.feytons@gmail.com>
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49183 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/utils/curl/Config.in
package/network/utils/curl/Makefile

index f41307a..14d2047 100644 (file)
@@ -154,4 +154,9 @@ config LIBCURL_VERBOSE
        bool "Enable verbose error strings"
        default n
 
+config LIBCURL_NTLM
+       bool "Enable NTLM support"
+       depends LIBCURL_CRYPTO_AUTH && !LIBCURL_NOSSL
+       default n
+
 endif
index eada1aa..319c0b7 100644 (file)
@@ -65,7 +65,8 @@ PKG_CONFIG_DEPENDS:= \
   CONFIG_LIBCURL_THREADED_RESOLVER \
   CONFIG_LIBCURL_TLS_SRP \
   CONFIG_LIBCURL_UNIX_SOCKETS \
-  CONFIG_LIBCURL_VERBOSE
+  CONFIG_LIBCURL_VERBOSE \
+  CONFIG_LIBCURL_NTLM
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -99,6 +100,7 @@ define Package/libcurl/config
 endef
 
 TARGET_CFLAGS += $(FPIC)
+TARGET_CPPFLAGS += $(if $(CONFIG_LIBCURL_NTLM),,-DCURL_DISABLE_NTLM)
 
 CONFIGURE_ARGS += \
        --disable-debug \