x86: remove pata-amd driver from generic x86 images, add addition cs553x modules
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 31 May 2011 16:57:01 +0000 (16:57 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 31 May 2011 16:57:01 +0000 (16:57 +0000)
The pata-cs5535/pata-cs5536 driver is actually fairly rare: it only gets used on embedded platforms. Therefore, we remove it from the generic x86 configuration.

Also, add definitions for other useful geode modules (high-res timers, MFGPT timers, etc).

Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27037 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/block.mk
package/kernel/modules/other.mk
target/linux/x86/alix2/config-default
target/linux/x86/config-default
target/linux/x86/generic/config-default
target/linux/x86/geos/config-default

index 2893580..218d048 100644 (file)
@@ -471,6 +471,70 @@ endef
 $(eval $(call KernelPackage,ide-it821x))
 
 
+define KernelPackage/cs5535
+  TITLE:=NSC/AMD CS5535 chipset support
+  DEPENDS:=@TARGET_x86
+  KCONFIG:=CONFIG_BLK_DEV_CS5535
+  FILES=$(LINUX_DIR)/drivers/ide/cs5535.ko
+  AUTOLOAD:=$(call AutoLoad,30,cs5535,1)
+  $(call AddDepends/ide)
+endef
+
+define KernelPackage/cs5535/description
+  Kernel module for the NSC/AMD CS5535 companion chip
+endef
+
+$(eval $(call KernelPackage,cs5535))
+
+
+define KernelPackage/cs5536
+  TITLE:=AMD CS5536 chipset support
+  DEPENDS:=@TARGET_x86
+  KCONFIG:=CONFIG_BLK_DEV_CS5536
+  FILES=$(LINUX_DIR)/drivers/ide/cs5536.ko
+  AUTOLOAD:=$(call AutoLoad,30,cs5536,1)
+  $(call AddDepends/ide)
+endef
+
+define KernelPackage/cs5536/description
+  Kernel module for the AMD CS5536 Geode LX companion chip
+endef
+
+$(eval $(call KernelPackage,cs5536))
+
+
+define KernelPackage/pata-cs5535
+  TITLE:=CS5535 PATA support
+  DEPENDS:=@TARGET_x86 @PCI_SUPPORT
+  KCONFIG:=CONFIG_PATA_CS5535
+  FILES=$(LINUX_DIR)/drivers/ata/pata-cs5535.ko
+  AUTOLOAD:=$(call AutoLoad,30,pata-cs5535,1)
+  $(call AddDepends/ata)
+endef
+
+define KernelPackage/cs5535/description
+  Kernel module for the NSC/AMD CS5535 companion chip
+endef
+
+$(eval $(call KernelPackage,cs5535))
+
+
+define KernelPackage/pata-cs5536
+  TITLE:=CS5536 PATA support
+  DEPENDS:=@TARGET_x86 @PCI_SUPPORT
+  KCONFIG:=CONFIG_PATA_CS5536
+  FILES=$(LINUX_DIR)/drivers/ata/pata-cs5536.ko
+  AUTOLOAD:=$(call AutoLoad,30,pata-cs5536,1)
+  $(call AddDepends/ata)
+endef
+
+define KernelPackage/cs5536/description
+  Kernel module for the AMD CS5536 Geode LX companion chip
+endef
+
+$(eval $(call KernelPackage,cs5536))
+
+
 define KernelPackage/libsas
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=SAS Domain Transport Attributes
index 3e17dc3..b46e56e 100644 (file)
@@ -519,7 +519,7 @@ $(eval $(call KernelPackage,ssb))
 define KernelPackage/wdt-geode
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Geode/LX Watchdog timer
-  DEPENDS:=@TARGET_x86
+  DEPENDS:=@TARGET_x86 +kmod-cs5535-mfgpt
   KCONFIG:=CONFIG_GEODE_WDT
   FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/geodewdt.ko
   AUTOLOAD:=$(call AutoLoad,50,geodewdt)
@@ -532,6 +532,38 @@ endef
 $(eval $(call KernelPackage,wdt-geode))
 
 
+define KernelPackage/cs5535-clockevt
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=CS5535/CS5536 high-res timer (MFGPT) events
+  DEPENDS:=@TARGET_x86 +kmod-cs5535-mfgpt
+  KCONFIG:=CONFIG_CS5535_CLOCK_EVENT_SRC
+  FILES:=$(LINUX_DIR)/drivers/clocksource/cs5535-clockevt.ko
+  AUTOLOAD:=$(call AutoLoad,50,cs5535-clockevt)
+endef
+
+define KernelPackage/cs5535-clockevt/description
+  Kernel module for CS5535/6 high-res clock event source
+endef
+
+$(eval $(call KernelPackage,cs5535-clockevt))
+
+
+define KernelPackage/cs5535-mfgpt
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=CS5535/6 Multifunction General Purpose Timer
+  DEPENDS:=@TARGET_x86
+  KCONFIG:=CONFIG_CS5535_MFGPT
+  FILES:=$(LINUX_DIR)/drivers/misc/cs5535-mfgpt.ko
+  AUTOLOAD:=$(call AutoLoad,45,cs5535-mfgpt)
+endef
+
+define KernelPackage/cs5535-mfgpt/description
+  Kernel module for CS5535/6 multifunction general purpose timer.
+endef
+
+$(eval $(call KernelPackage,cs5535-mfgpt))
+
+
 define KernelPackage/wdt-omap
   SUBMENU:=$(OTHER_MENU)
   TITLE:=OMAP Watchdog timer
index e77b409..002c753 100644 (file)
@@ -40,3 +40,5 @@ CONFIG_X86_L1_CACHE_SHIFT=5
 CONFIG_X86_TSC=y
 CONFIG_X86_USE_3DNOW=y
 CONFIG_X86_USE_PPRO_CHECKSUM=y
+# CONFIG_CS5535_CLOCK_EVENT_SRC is not set
+CONFIG_PATA_CS5536=y
index 41666da..1d20fd6 100644 (file)
@@ -271,7 +271,7 @@ CONFIG_OUTPUT_FORMAT="elf32-i386"
 CONFIG_PAGEFLAGS_EXTENDED=y
 CONFIG_PAGE_OFFSET=0xC0000000
 # CONFIG_PARAVIRT_GUEST is not set
-CONFIG_PATA_AMD=y
+# CONFIG_PATA_AMD is not set
 CONFIG_PATA_MPIIX=y
 CONFIG_PATA_OLDPIIX=y
 CONFIG_PATA_SC1200=y
index 4c4f1b2..252e938 100644 (file)
@@ -54,6 +54,7 @@ CONFIG_MOUSE_PS2_TRACKPOINT=y
 # CONFIG_MOUSE_VSXXXAA is not set
 CONFIG_PATA_LEGACY=y
 CONFIG_PATA_PLATFORM=y
+CONFIG_PATA_AMD=y
 CONFIG_PCIEAER=y
 CONFIG_PCIEPORTBUS=y
 CONFIG_VT=y
index 33e12a6..d795f1a 100644 (file)
@@ -28,3 +28,5 @@ CONFIG_X86_TSC=y
 CONFIG_X86_USE_3DNOW=y
 CONFIG_X86_USE_PPRO_CHECKSUM=y
 CONFIG_GPIOLIB=y
+# CONFIG_CS5535_CLOCK_EVENT_SRC is not set
+CONFIG_PATA_CS5536=y