Prevent SSH keys from being chmoded to 644 (#664), looks like those are the only...
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 15 Oct 2006 23:03:46 +0000 (23:03 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 15 Oct 2006 23:03:46 +0000 (23:03 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5135 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/image.mk

index 0651679..c738146 100644 (file)
@@ -57,7 +57,7 @@ endif
 
 
 define Image/mkfs/prepare/default
-       find $(BUILD_DIR)/root -type f -not -perm +0100 | xargs chmod 0644
+       find $(BUILD_DIR)/root -type f -not -perm +0100 -not -name 'ssh_host*' | xargs chmod 0644
        find $(BUILD_DIR)/root -type f -perm +0100 | xargs chmod 0755
        find $(BUILD_DIR)/root -type d | xargs chmod 0755
        mkdir -p $(BUILD_DIR)/root/tmp