lldpd: disable xml explicitly
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 31 May 2015 17:46:09 +0000 (17:46 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 31 May 2015 17:46:09 +0000 (17:46 +0000)
This prevents auto-detection of libxml2 and thus the error:
Package lldpd is missing dependencies for the following libraries:
libxml2.so.2

Preventing a dependency to libxml2 is preferred, since libxml2
would be a out-of-(core-)tree dependency.

Reported-by: Buildbot
Signed-off-by: Michael Heimpold <mhei@heimpold.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45859 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/services/lldpd/Makefile

index 69f7022..cccb9ba 100644 (file)
@@ -93,6 +93,7 @@ CONFIGURE_ARGS += \
        --with-readline=no \
        --with-embedded-libevent=no \
        --disable-hardening \
+       --without-xml \
        $(if $(CONFIG_LLDPD_WITH_CDP),,--disable-cdp) \
        $(if $(CONFIG_LLDPD_WITH_FDP),,--disable-fdp) \
        $(if $(CONFIG_LLDPD_WITH_EDP),,--disable-edp) \