Added httping
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 13 Feb 2006 12:40:39 +0000 (12:40 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 13 Feb 2006 12:40:39 +0000 (12:40 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@3230 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/Config.in
package/Makefile
package/config/Makefile
package/httping/Config.in [new file with mode: 0644]
package/httping/Makefile [new file with mode: 0644]
package/httping/ipkg/httping.control [new file with mode: 0644]

index b2a54b8..e69cad2 100644 (file)
@@ -76,6 +76,7 @@ source "package/howl/Config.in"
 source "package/hostap-utils/Config.in"
 source "package/hostapd/Config.in"
 source "package/htpdate/Config.in"
+source "package/httping/Config.in"
 source "package/iftop/Config.in"
 source "package/ipcad/Config.in"
 source "package/iproute2/Config.in"
index 927ad57..d16f84d 100644 (file)
@@ -62,6 +62,7 @@ package-$(BR2_PACKAGE_HOSTAP_UTILS) += hostap-utils
 package-$(BR2_PACKAGE_HOSTAPD) += hostapd
 package-$(BR2_COMPILE_HOWL) += howl
 package-$(BR2_PACKAGE_HTPDATE) += htpdate
+package-$(BR2_PACKAGE_HTTPING) += httping
 package-$(BR2_PACKAGE_ICECAST) += icecast
 package-$(BR2_PACKAGE_ID3LIB) += id3lib
 package-$(BR2_PACKAGE_IFTOP) += iftop
index 9e841d9..846b04c 100644 (file)
@@ -9,6 +9,7 @@ HOSTCC    = gcc
 HOSTCFLAGS= -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer
 # Ensure consistent sort order, 'gcc -print-search-dirs' behavior, etc.
 LC_ALL:= C
+CP:=cp -a
 
 
 all: ncurses conf mconf
diff --git a/package/httping/Config.in b/package/httping/Config.in
new file mode 100644 (file)
index 0000000..a818905
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_HTTPING
+       prompt "httping........................... Httping is like 'ping' but for http-requests."
+       tristate
+       default m if CONFIG_DEVEL
+       help
+         Httping is like 'ping' but for http-requests.
+         Give it an url, and it'll show you how long it takes to connect, send a 
+         request and retrieve the reply (only the headers). Be aware that the 
+         transmission across the network also takes time!
+
+         http://www.vanheusden.com/httping/
diff --git a/package/httping/Makefile b/package/httping/Makefile
new file mode 100644 (file)
index 0000000..aaab6ab
--- /dev/null
@@ -0,0 +1,36 @@
+# $Id: Makefile 1146 2005-06-05 13:32:28Z florian $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=httping
+PKG_VERSION:=1.0.10
+PKG_RELEASE:=1
+PKG_MD5SUM:=998b00b8babeb3196d28c20ad87d9c15
+
+PKG_SOURCE_URL:=http://www.vanheusden.com/httping/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,HTTPING,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC=$(TARGET_CC)
+       touch $@
+
+$(IPKG_HTTPING): 
+       mkdir -p $(IDIR_HTTPING)/usr/sbin
+       cp $(PKG_BUILD_DIR)/$(PKG_NAME) $(IDIR_HTTPING)/usr/sbin/
+       $(STRIP) $(IDIR_HTTPING)/usr/sbin/*
+       $(IPKG_BUILD) $(IDIR_HTTPING) $(PACKAGE_DIR)
+
+mostlyclean:
+       $(MAKE) -C $(PKG_BUILD_DIR) clean
+       rm -f $(PKG_BUILD_DIR)/.built
diff --git a/package/httping/ipkg/httping.control b/package/httping/ipkg/httping.control
new file mode 100644 (file)
index 0000000..5ab31d9
--- /dev/null
@@ -0,0 +1,4 @@
+Package: httping
+Section: net
+Priority: optional
+Description: Httping is like 'ping' but for http-requests.