[include] autotools.mk: add a (dummy) libintl build dependency to any package using...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 19 Dec 2010 02:37:56 +0000 (02:37 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 19 Dec 2010 02:37:56 +0000 (02:37 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24700 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/autotools.mk

index 5e1c105..592fcde 100644 (file)
@@ -61,14 +61,14 @@ define autoreconf_target
 endef
 
 ifneq ($(filter libtool,$(PKG_FIXUP)),)
-  PKG_BUILD_DEPENDS += libtool
+  PKG_BUILD_DEPENDS += libtool libintl
  ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
   Hooks/Configure/Pre += autoreconf_target
  endif
 endif
 
 ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
-  PKG_BUILD_DEPENDS += libtool
+  PKG_BUILD_DEPENDS += libtool libintl
  ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
   Hooks/Configure/Pre += autoreconf_target
  endif