kernel: deactivate ext4 SElinux support and extended attributes support
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 9 Jan 2011 22:43:06 +0000 (22:43 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 9 Jan 2011 22:43:06 +0000 (22:43 +0000)
in general config. This effects the build in kmod-fs-ext4 and when it
is build into the kernel in the x86 target.

Thank you Philip Prindeville

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24951 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/fs.mk
target/linux/generic/config-2.6.30
target/linux/generic/config-2.6.31
target/linux/generic/config-2.6.32
target/linux/generic/config-2.6.34
target/linux/generic/config-2.6.35
target/linux/generic/config-2.6.36
target/linux/generic/config-2.6.37

index e5714aa..846bc82 100644 (file)
@@ -112,10 +112,6 @@ define KernelPackage/fs-ext4
   SUBMENU:=$(FS_MENU)
   TITLE:=EXT4 filesystem support
   KCONFIG:= \
-       CONFIG_EXT4DEV_COMPAT=n \
-       CONFIG_EXT4_FS_XATTR=y \
-       CONFIG_EXT4_FS_POSIX_ACL=y \
-       CONFIG_EXT4_FS_SECURITY=y \
        CONFIG_EXT4_FS \
        CONFIG_JBD2
   DEPENDS:= $(if $(DUMP)$(CONFIG_FS_MBCACHE),+kmod-fs-mbcache)
index 6e7d6a7..87e8c6d 100644 (file)
@@ -521,6 +521,8 @@ CONFIG_EXPERIMENTAL=y
 # CONFIG_EXT4DEV_COMPAT is not set
 # CONFIG_EXT4DEV_FS is not set
 # CONFIG_EXT4_FS is not set
+# CONFIG_EXT4_FS_SECURITY is not set
+# CONFIG_EXT4_FS_XATTR is not set
 CONFIG_EXTRA_FIRMWARE=""
 CONFIG_EXTRA_TARGETS=""
 # CONFIG_FAIR_GROUP_SCHED is not set
index e664748..96f955e 100644 (file)
@@ -502,8 +502,11 @@ CONFIG_EXPERIMENTAL=y
 # CONFIG_EXT3_DEFAULTS_TO_ORDERED is not set
 # CONFIG_EXT3_FS is not set
 # CONFIG_EXT3_FS_XATTR is not set
+# CONFIG_EXT4DEV_COMPAT is not set
 # CONFIG_EXT4DEV_FS is not set
 # CONFIG_EXT4_FS is not set
+# CONFIG_EXT4_FS_SECURITY is not set
+# CONFIG_EXT4_FS_XATTR is not set
 CONFIG_EXTRA_FIRMWARE=""
 CONFIG_EXTRA_TARGETS=""
 # CONFIG_EZX_PCAP is not set
index 2e7756c..5e3733a 100644 (file)
@@ -552,6 +552,7 @@ CONFIG_EXPERIMENTAL=y
 # CONFIG_EXT4DEV_FS is not set
 # CONFIG_EXT4_DEBUG is not set
 # CONFIG_EXT4_FS is not set
+# CONFIG_EXT4_FS_SECURITY is not set
 # CONFIG_EXT4_FS_XATTR is not set
 CONFIG_EXT4_USE_FOR_EXT23=y
 CONFIG_EXTRA_FIRMWARE=""
index 7f17618..9209458 100644 (file)
@@ -569,6 +569,8 @@ CONFIG_EXPERIMENTAL=y
 # CONFIG_EXT4DEV_FS is not set
 # CONFIG_EXT4_DEBUG is not set
 # CONFIG_EXT4_FS is not set
+# CONFIG_EXT4_FS_SECURITY is not set
+# CONFIG_EXT4_FS_XATTR is not set
 CONFIG_EXT4_USE_FOR_EXT23=y
 CONFIG_EXTRA_FIRMWARE=""
 CONFIG_EXTRA_TARGETS=""
index 8e1b16d..8f64f34 100644 (file)
@@ -594,6 +594,7 @@ CONFIG_EXPERIMENTAL=y
 # CONFIG_EXT4DEV_FS is not set
 # CONFIG_EXT4_DEBUG is not set
 # CONFIG_EXT4_FS is not set
+# CONFIG_EXT4_FS_SECURITY is not set
 # CONFIG_EXT4_FS_XATTR is not set
 CONFIG_EXT4_USE_FOR_EXT23=y
 CONFIG_EXTRA_FIRMWARE=""
index 0bc1175..45dbde0 100644 (file)
@@ -565,6 +565,7 @@ CONFIG_EXPERIMENTAL=y
 # CONFIG_EXT3_FS_XATTR is not set
 # CONFIG_EXT4_DEBUG is not set
 # CONFIG_EXT4_FS is not set
+# CONFIG_EXT4_FS_SECURITY is not set
 # CONFIG_EXT4_FS_XATTR is not set
 CONFIG_EXT4_USE_FOR_EXT23=y
 CONFIG_EXTRA_FIRMWARE=""
index 7e7685a..b8fa600 100644 (file)
@@ -564,6 +564,7 @@ CONFIG_EXPERIMENTAL=y
 # CONFIG_EXT3_FS_XATTR is not set
 # CONFIG_EXT4_DEBUG is not set
 # CONFIG_EXT4_FS is not set
+# CONFIG_EXT4_FS_SECURITY is not set
 # CONFIG_EXT4_FS_XATTR is not set
 CONFIG_EXT4_USE_FOR_EXT23=y
 CONFIG_EXTRA_FIRMWARE=""