Add jsonpath - a command line utility to extract values from JSON data using XPath...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 2 Jan 2014 11:55:16 +0000 (11:55 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 2 Jan 2014 11:55:16 +0000 (11:55 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39185 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/utils/jsonpath/Makefile [new file with mode: 0644]

diff --git a/package/utils/jsonpath/Makefile b/package/utils/jsonpath/Makefile
new file mode 100644 (file)
index 0000000..9e44cf2
--- /dev/null
@@ -0,0 +1,31 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=jsonpath
+PKG_VERSION:=2014-01-02
+PKG_RELEASE=$(PKG_SOURCE_VERSION)
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=git://git.openwrt.org/project/jsonpath.git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=325454c60f282994cf79c69d49edbcea53f2e924
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
+CMAKE_INSTALL:=1
+
+PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+define Package/jsonpath
+  SECTION:=base
+  CATEGORY:=Base system
+  DEPENDS:=+libubox +libjson-c
+  TITLE:=OpenWrt JSON query utility
+endef
+
+define Package/jsonpath/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/jsonpath $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,jsonpath))