lldpd: add Build/InstallDev rule
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 21 Mar 2015 21:47:34 +0000 (21:47 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 21 Mar 2015 21:47:34 +0000 (21:47 +0000)
For using liblldpctl to talk to lldpd (via unix sockets).

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44924 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/services/lldpd/Makefile

index f038a34..ff367f1 100644 (file)
@@ -49,6 +49,14 @@ define Package/lldpd/description
        Link-Layer notifications to adjacent network devices.
 endef
 
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/liblldpctl.so* $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/lldpctl.h $(1)/usr/include/lldpctl.h
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/lldp-const.h $(1)/usr/include/lldp-const.h
+endef
+
 define Package/lldpd/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_DIR) $(1)/etc/lldpd.d