ramips: mt7621: fix WF-2881 for ubi split
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 4 Mar 2016 08:33:17 +0000 (08:33 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 4 Mar 2016 08:33:17 +0000 (08:33 +0000)
This patch fix firmware split for WF-2881 which was previously manually partitioned.

Signed-off-by: YounJae Rho <luxflow@live.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48908 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/dts/WF-2881.dts
target/linux/ramips/image/Makefile

index aaafe5a..d33436c 100644 (file)
                        read-only;
                };
 
                        read-only;
                };
 
-               firmware {
-                       label = "firmware";
-                       reg = <0x140000 0x6EC0000>;
-               };
-
                partition@140000 {
                partition@140000 {
-                       label = "kernel";
-                       reg = <0x140000 0x200000>;
-               };
-
-               partition@340000 {
-                       label = "ubi";
-                       reg = <0x340000 0x6CC0000>;
+                       label = "firmware";
+                       reg = <0x140000 0x7E40000>;
                };
        };
 
                };
        };
 
index eb50cdd..f5e8e58 100644 (file)
@@ -1115,9 +1115,10 @@ define Device/wf-2881
   DTS := WF-2881
   BLOCKSIZE := 128KiB
   PAGESIZE := 2048
   DTS := WF-2881
   BLOCKSIZE := 128KiB
   PAGESIZE := 2048
-  KERNEL_SIZE := 2097152
   FILESYSTEMS := squashfs
   FILESYSTEMS := squashfs
-  IMAGE/sysupgrade.bin := append-kernel | pad-to $$(KERNEL_SIZE) | append-ubi | check-size $$$$(IMAGE_SIZE)
+  IMAGE_SIZE := 132382720
+  KERNEL := $(KERNEL_DTB) | pad-offset 131072 64 | uImage lzma
+  IMAGE/sysupgrade.bin := append-kernel | append-ubi | check-size $$$$(IMAGE_SIZE)
 endef
 
 define Device/ubnt-erx
 endef
 
 define Device/ubnt-erx