ltq-vdsl-mei: activate format security checks
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 25 Feb 2016 21:59:56 +0000 (21:59 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 25 Feb 2016 21:59:56 +0000 (21:59 +0000)
This activates the format warnings in this package and that makes it
possible to activate format-security checks.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48785 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/lantiq/ltq-vdsl-mei/Makefile
package/kernel/lantiq/ltq-vdsl-mei/patches/010-warnings.patch

index 64a7cf3..e0617ae 100644 (file)
@@ -19,7 +19,6 @@ PKG_MD5SUM:=78bf61dbc3421123c6716b874a930759
 PKG_FIXUP:=autoreconf
 PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
 PKG_USE_MIPS16:=0
-PKG_CHECK_FORMAT_SECURITY:=0
 
 include $(INCLUDE_DIR)/package.mk
 
index a3c7dfe..04fa36b 100644 (file)
  
     if (pDynNfc->pRecvDataCntrl[pDynNfc->rdIdxRd].bufCtrl != MEI_RECV_BUF_CTRL_FREE)      /* buffer in use */
     {
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -201,7 +201,7 @@ else
+ drv_mei_cpe_common_cflags = \
+       $(AM_CFLAGS) -D__KERNEL__ -DLINUX -D__linux__ -DMODULE -DEXPORT_SYMTAB \
+-      -pipe -Wno-format -Wimplicit -Wunused -Wuninitialized -Wsign-compare -Wstrict-aliasing
++      -pipe -Wall -Wimplicit -Wunused -Wuninitialized -Wstrict-aliasing
+ endif