kernel: update to version 3.0.3
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 18 Aug 2011 12:54:12 +0000 (12:54 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 18 Aug 2011 12:54:12 +0000 (12:54 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28043 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/kernel-version.mk
target/linux/brcm47xx/Makefile
target/linux/brcm47xx/patches-3.0/0015-ssb-add-serial-flash-support.patch
target/linux/brcm47xx/patches-3.0/220-bcm5354.patch
target/linux/generic/patches-3.0/950-vm_exports.patch
target/linux/malta/Makefile
target/linux/orion/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/realview/Makefile
target/linux/uml/Makefile

index 530fae2..1b41d84 100644 (file)
@@ -29,8 +29,8 @@ endif
 ifeq ($(LINUX_VERSION),2.6.39.4)
   LINUX_KERNEL_MD5SUM:=a17c748c2070168f1e784e9605ca043d
 endif
-ifeq ($(LINUX_VERSION),3.0.1)
-  LINUX_KERNEL_MD5SUM:=aed949984b878b7fb77ffe9cbee8ce0c
+ifeq ($(LINUX_VERSION),3.0.3)
+  LINUX_KERNEL_MD5SUM:=6a8af5f6733b3db970197e65b3db712c
 endif
 
 # disable the md5sum check for unknown kernel versions
index 167d9e4..ce5e862 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=brcm47xx
 BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=squashfs usb pcmcia
 
-LINUX_VERSION:=3.0.1
+LINUX_VERSION:=3.0.3
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-switch kmod-diag nvram
index 1e7762b..e91c2a4 100644 (file)
@@ -601,7 +601,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
 +}
 --- a/drivers/ssb/driver_mipscore.c
 +++ b/drivers/ssb/driver_mipscore.c
-@@ -193,7 +193,13 @@ static void ssb_mips_flash_detect(struct
+@@ -203,7 +203,13 @@ static void ssb_mips_flash_detect(struct
        switch (bus->chipco.capabilities & SSB_CHIPCO_CAP_FLASHT) {
        case SSB_CHIPCO_FLASHT_STSER:
        case SSB_CHIPCO_FLASHT_ATSER:
index 7d7ca8e..6055e0a 100644 (file)
@@ -20,7 +20,7 @@
        switch (*plltype) {
 --- a/drivers/ssb/driver_mipscore.c
 +++ b/drivers/ssb/driver_mipscore.c
-@@ -234,6 +234,8 @@ u32 ssb_cpu_clock(struct ssb_mipscore *m
+@@ -241,6 +241,8 @@ u32 ssb_cpu_clock(struct ssb_mipscore *m
  
        if ((pll_type == SSB_PLLTYPE_5) || (bus->chip_id == 0x5365)) {
                rate = 200000000;
index e1b88a0..4be67a3 100644 (file)
@@ -89,7 +89,7 @@
   * We enter with non-exclusive mmap_sem (to exclude vma changes,
 --- a/mm/vmalloc.c
 +++ b/mm/vmalloc.c
-@@ -1245,6 +1245,7 @@ void unmap_kernel_range(unsigned long ad
+@@ -1246,6 +1246,7 @@ void unmap_kernel_range(unsigned long ad
        vunmap_page_range(addr, end);
        flush_tlb_kernel_range(addr, end);
  }
@@ -97,7 +97,7 @@
  
  int map_vm_area(struct vm_struct *area, pgprot_t prot, struct page ***pages)
  {
-@@ -1360,6 +1361,7 @@ struct vm_struct *get_vm_area(unsigned l
+@@ -1361,6 +1362,7 @@ struct vm_struct *get_vm_area(unsigned l
        return __get_vm_area_node(size, 1, flags, VMALLOC_START, VMALLOC_END,
                                -1, GFP_KERNEL, __builtin_return_address(0));
  }
index 8f64714..2c884df 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=le be
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.0.1
+LINUX_VERSION:=3.0.3
 
 include $(INCLUDE_DIR)/target.mk
 
index a8201f5..54e0c37 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=generic harddisk
 CFLAGS=-Os -pipe -march=armv5te -mtune=xscale -fno-caller-saves
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.0.1
+LINUX_VERSION:=3.0.3
 
 include $(INCLUDE_DIR)/target.mk
 
index ffd1b44..b2cb3a2 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.0.1
+LINUX_VERSION:=3.0.3
 
 include $(INCLUDE_DIR)/target.mk
 
index 8f65693..0de8282 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.0.1
+LINUX_VERSION:=3.0.3
 
 include $(INCLUDE_DIR)/target.mk
 
index e697ba6..e758ea7 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=fpu ramdisk
 CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.0.1
+LINUX_VERSION:=3.0.3
 
 include $(INCLUDE_DIR)/target.mk
 
index a91aac8..1f7b3fb 100644 (file)
@@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
 FEATURES:=ext4 audio
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.0.1
+LINUX_VERSION:=3.0.3
 
 include $(INCLUDE_DIR)/target.mk