replace gen_busybox_config.pl with a simple sed command
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 4 Apr 2007 16:11:28 +0000 (16:11 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 4 Apr 2007 16:11:28 +0000 (16:11 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6864 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/busybox/Makefile
scripts/gen_busybox_config.pl [deleted file]

index 90e3af0..03a0ebd 100644 (file)
@@ -51,7 +51,7 @@ endef
 
 define Build/Configure
        rm -f $(PKG_BUILD_DIR)/.configured*
-       $(SCRIPT_DIR)/gen_busybox_config.pl $(TOPDIR)/.config > $(PKG_BUILD_DIR)/.config
+       grep 'CONFIG_BUSYBOX_' $(TOPDIR)/.config | sed -e "s,\\(# \)\\?CONFIG_BUSYBOX_\\(.*\\),\\1\\2,g" > $(PKG_BUILD_DIR)/.config
        yes '' | $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
                CROSS_COMPILE="$(TARGET_CROSS)" \
diff --git a/scripts/gen_busybox_config.pl b/scripts/gen_busybox_config.pl
deleted file mode 100755 (executable)
index 9360052..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-#!/usr/bin/perl
-# 
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-use strict;
-
-my $line;
-my $l1 = '';
-my $l2 = '=y';
-while (<>) {
-       chomp;
-       /^(# )CONFIG_LARGEFILE(.+)$/ and do {
-               $l1 = $1;
-               $l2 = $2;
-       };
-       /^(# )?CONFIG_BUSYBOX_(.+)/ and do {
-               my $p1 = $1;
-               my $p2 = $2;
-               $p2 =~ /(CONFIG_LFS|FDISK_SUPPORT_LARGE_DISKS)/ and do {
-                       $p1 = $l1;
-                       $p2 = "$1$l2";
-               };
-               print "$p1$p2\n";
-       }
-}