linux/crypto: Add echainiv module provided by 4.4 kernels
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 12 Feb 2016 08:31:54 +0000 (08:31 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 12 Feb 2016 08:31:54 +0000 (08:31 +0000)
This module is needed for IPsec ESP support, i.e..

Signed-off-by: André Valentin <avalentin@marcant.net>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48714 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/crypto.mk

index a47a1b6..dddddcc 100644 (file)
@@ -133,6 +133,18 @@ endef
 
 $(eval $(call KernelPackage,crypto-iv))
 
+
+define KernelPackage/crypto-echainiv
+  TITLE:=Encrypted Chain IV Generator
+  KCONFIG:=CONFIG_CRYPTO_ECHAINIV
+  FILES:=$(LINUX_DIR)/crypto/echainiv.ko
+  AUTOLOAD:=$(call AutoLoad,09,echainiv)
+  $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-echainiv))
+
+
 define KernelPackage/crypto-seqiv
   TITLE:=CryptoAPI Sequence Number IV Generator
   DEPENDS:=+kmod-crypto-aead +kmod-crypto-rng