revert last change and add a different fix
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 21 Jun 2006 23:45:47 +0000 (23:45 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 21 Jun 2006 23:45:47 +0000 (23:45 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4046 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/iptables/Makefile

index 35bba6d..f8f5909 100644 (file)
@@ -21,6 +21,10 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 PKG_MENU:=IPv4 / IPv6 firewall administration
 
 include $(INCLUDE_DIR)/package.mk
+ifeq ($(DUMP),)
+-include $(LINUX_DIR)/.config
+include $(INCLUDE_DIR)/netfilter.mk
+endif
 
 define Package/iptables
 SECTION:=net
@@ -209,9 +213,6 @@ define Package/ip6tables/install
 endef
 
 define BuildPlugin
-include $(LINUX_DIR)/.config
-include $(INCLUDE_DIR)/netfilter.mk
-
 define Package/$(1)/install
        install -m0755 -d $$(1)/usr/lib/iptables
        for m in $$(patsubst xt_%,ipt_%,$(2)); do \