ar71xx: add support for the OpenMesh OM2P-LC board
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 5 Jul 2012 08:26:53 +0000 (08:26 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 5 Jul 2012 08:26:53 +0000 (08:26 +0000)
Patch-by: Marek Linder <marek@open-mesh.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32611 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/base-files/etc/diag.sh
target/linux/ar71xx/base-files/etc/uci-defaults/leds
target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/files/arch/mips/ath79/mach-om2p.c
target/linux/ar71xx/generic/profiles/openmesh.mk
target/linux/ar71xx/patches-3.3/610-MIPS-ath79-openwrt-machines.patch

index 76518bd..f52012f 100755 (executable)
@@ -84,7 +84,8 @@ get_status_led() {
        nbg460n_550n_550nh)
                status_led="nbg460n:green:power"
                ;;
-       om2p)
+       om2p | \
+       om2p-lc)
                status_led="om2p:blue:power"
                ;;
        pb44)
index 0415221..e32d33d 100755 (executable)
@@ -63,7 +63,8 @@ nbg460n_550n_550nh)
        ucidef_set_led_wlan "wlan" "WLAN" "nbg460n:green:wlan" "phy0tpt"
        ;;
 
-om2p)
+om2p | \
+om2p-lc)
        ucidef_set_led_netdev "port1" "port1" "om2p:blue:wan" "eth0"
        ucidef_set_led_netdev "port2" "port2" "om2p:blue:lan" "eth1"
        ;;
index 40e76d5..702fa7e 100755 (executable)
@@ -225,6 +225,9 @@ ar71xx_board_detect() {
        *OM2P)
                name="om2p"
                ;;
+       *"OM2P LC")
+               name="om2p-lc"
+               ;;
        *PB42)
                name="pb42"
                ;;
index 519640a..faeb49a 100644 (file)
@@ -22,6 +22,7 @@
 #include "dev-gpio-buttons.h"
 #include "dev-leds-gpio.h"
 #include "dev-m25p80.h"
+#include "dev-wmac.h"
 #include "machtypes.h"
 
 #define OM2P_GPIO_LED_POWER    0
 
 #define OM2P_WAN_PHYMASK       BIT(4)
 
+#define OM2P_LC_GPIO_LED_POWER 1
+#define OM2P_LC_GPIO_LED_GREEN 15
+#define OM2P_LC_GPIO_LED_RED   16
+#define OM2P_LC_GPIO_LED_YELLOW        0
+#define OM2P_LC_GPIO_LED_LAN   13
+#define OM2P_LC_GPIO_LED_WAN   17
+#define OM2P_LC_GPIO_BTN_RESET 12
+
 static struct flash_platform_data om2p_flash_data = {
        .type = "s25sl12800",
        .name = "ar7240-nor0",
@@ -114,3 +123,54 @@ static void __init om2p_setup(void)
 }
 
 MIPS_MACHINE(ATH79_MACH_OM2P, "OM2P", "OpenMesh OM2P", om2p_setup);
+
+
+static struct flash_platform_data om2p_lc_flash_data = {
+       .type = "s25sl12800",
+};
+
+static void __init om2p_lc_setup(void)
+{
+       u8 *mac1 = (u8 *)KSEG1ADDR(0x1ffc0000);
+       u8 *mac2 = (u8 *)KSEG1ADDR(0x1ffc0000 + ETH_ALEN);
+       u8 *art = (u8 *)KSEG1ADDR(0x1ffc1000);
+       u32 t;
+
+       ath79_gpio_function_disable(AR933X_GPIO_FUNC_ETH_SWITCH_LED0_EN |
+                                   AR933X_GPIO_FUNC_ETH_SWITCH_LED1_EN |
+                                   AR933X_GPIO_FUNC_ETH_SWITCH_LED2_EN |
+                                   AR933X_GPIO_FUNC_ETH_SWITCH_LED3_EN |
+                                   AR933X_GPIO_FUNC_ETH_SWITCH_LED4_EN);
+
+       t = ath79_reset_rr(AR933X_RESET_REG_BOOTSTRAP);
+       t |= AR933X_BOOTSTRAP_MDIO_GPIO_EN;
+       ath79_reset_wr(AR933X_RESET_REG_BOOTSTRAP, t);
+
+       ath79_register_m25p80(&om2p_lc_flash_data);
+
+       om2p_leds_gpio[0].gpio = OM2P_LC_GPIO_LED_POWER;
+       om2p_leds_gpio[1].gpio = OM2P_LC_GPIO_LED_RED;
+       om2p_leds_gpio[2].gpio = OM2P_LC_GPIO_LED_YELLOW;
+       om2p_leds_gpio[3].gpio = OM2P_LC_GPIO_LED_GREEN;
+       om2p_leds_gpio[4].gpio = OM2P_LC_GPIO_LED_LAN;
+       om2p_leds_gpio[5].gpio = OM2P_LC_GPIO_LED_WAN;
+       ath79_register_leds_gpio(-1, ARRAY_SIZE(om2p_leds_gpio),
+                                om2p_leds_gpio);
+
+       om2p_gpio_keys[0].gpio = OM2P_LC_GPIO_BTN_RESET;
+       ath79_register_gpio_keys_polled(-1, OM2P_KEYS_POLL_INTERVAL,
+                                       ARRAY_SIZE(om2p_gpio_keys),
+                                       om2p_gpio_keys);
+
+       ath79_init_mac(ath79_eth1_data.mac_addr, mac1, 0);
+       ath79_init_mac(ath79_eth0_data.mac_addr, mac2, 0);
+
+       ath79_register_mdio(0, 0x0);
+
+       ath79_register_eth(0);
+       ath79_register_eth(1);
+
+       ath79_register_wmac(art, NULL);
+}
+
+MIPS_MACHINE(ATH79_MACH_OM2P_LC, "OM2P-LC", "OpenMesh OM2P LC", om2p_lc_setup);
index 87d39f9..88e37ee 100644 (file)
@@ -6,12 +6,12 @@
 #
 
 define Profile/OM2P
-       NAME:=OpenMesh OM2P
+       NAME:=OpenMesh OM2P/OM2P-LC
        PACKAGES:=kmod-ath9k om-watchdog
 endef
 
 define Profile/OM2P/Description
-       Package set optimized for the OpenMesh OM2P.
+       Package set optimized for the OpenMesh OM2P/OM2P-LC.
 endef
 
 $(eval $(call Profile,OM2P))
index fe1c615..9351943 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -16,18 +16,87 @@
+@@ -16,18 +16,88 @@
  
  enum ath79_mach_type {
        ATH79_MACH_GENERIC = 0,
@@ -29,6 +29,7 @@
 +      ATH79_MACH_MZK_W04NU,           /* Planex MZK-W04NU */
 +      ATH79_MACH_MZK_W300NH,          /* Planex MZK-W300NH */
 +      ATH79_MACH_NBG460N,             /* Zyxel NBG460N/550N/550NH */
++      ATH79_MACH_OM2P_LC,             /* OpenMesh OM2P-LC */
 +      ATH79_MACH_OM2P,                /* OpenMesh OM2P */
 +      ATH79_MACH_PB42,                /* Atheros PB42 */
 +      ATH79_MACH_PB92,                /* Atheros PB92 */