[package] fix kmod-pcmcia-serial for 3.3+ kernels
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 27 Apr 2012 16:44:44 +0000 (16:44 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 27 Apr 2012 16:44:44 +0000 (16:44 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31490 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/pcmcia.mk

index 48112b0..7ea2599 100644 (file)
@@ -70,7 +70,11 @@ define KernelPackage/pcmcia-serial
        CONFIG_PCMCIA_SERIAL_CS \
        CONFIG_SERIAL_8250_CS
   ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.38)),1)
-    FILES:=$(LINUX_DIR)/drivers/tty/serial/serial_cs.ko
+    ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.3)),1)
+       FILES:=$(LINUX_DIR)/drivers/tty/serial/8250/serial_cs.ko
+    else
+       FILES:=$(LINUX_DIR)/drivers/tty/serial/serial_cs.ko
+    endif
   else
     FILES:=$(LINUX_DIR)/drivers/serial/serial_cs.ko
   endif