ar71xx: add profile and build image for the TL-WR1041N v2 board
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 5 May 2012 17:02:41 +0000 (17:02 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 5 May 2012 17:02:41 +0000 (17:02 +0000)
Patch-by: Vince Huang <axishero@foxmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31610 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/generic/profiles/tp-link.mk
target/linux/ar71xx/image/Makefile

index 96ff12a..5c18c44 100644 (file)
@@ -149,6 +149,17 @@ endef
 $(eval $(call Profile,TLWR941))
 
 
+define Profile/TLWR1041
+       NAME:=TP-LINK TL-WR1041N
+       PACKAGES:=
+endef
+
+define Profile/TLWR1041/Description
+       Package set optimized for the TP-LINK TL-WR1041N/ND.
+endef
+$(eval $(call Profile,TLWR1041))
+
+
 define Profile/TLWR1043
        NAME:=TP-LINK TL-WR1043N/ND
        PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
index 3df9625..f99c01a 100644 (file)
@@ -948,6 +948,11 @@ define Image/Build/Profile/TLWR941
        $(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK,tl-wr941nd-v4,$(tlwr941v4_cmdline),0x09410004,1,4M)
 endef
 
+tlwr1041_cmdline=board=TL-WR1041N-v2 console=ttyS0,115200
+define Image/Build/Profile/TLWR1041
+       $(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK-LZMA,tl-wr1041n-v2,$(tlwr1041_cmdline),0x10410002,1,8Mlzma)
+endef
+
 tlwr1043_cmdline=board=TL-WR1043ND console=ttyS0,115200
 define Image/Build/Profile/TLWR1043
        $(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK,tl-wr1043nd-v1,$(tlwr1043_cmdline),0x10430001,1,8M)
@@ -1087,6 +1092,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/TLWR841,$(1))
        $(call Image/Build/Profile/TLWR842,$(1))
        $(call Image/Build/Profile/TLWR941,$(1))
+       $(call Image/Build/Profile/TLWR1041,$(1))
        $(call Image/Build/Profile/TLWR1043,$(1))
        $(call Image/Build/Profile/TLWR2543,$(1))
        $(call Image/Build/Profile/UBNT,$(1))