[package] base-files: do not assume that "top" is busybox' top, but try to call the...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 8 Nov 2011 18:48:38 +0000 (18:48 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 8 Nov 2011 18:48:38 +0000 (18:48 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28862 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/base-files/Makefile
package/base-files/files/lib/upgrade/common.sh

index 2b1cfa1..e29e63b 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=89
+PKG_RELEASE:=90
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
index e0db37e..a5a6fbf 100644 (file)
@@ -80,7 +80,7 @@ run_ramfs() { # <command> [...]
 kill_remaining() { # [ <signal> ]
        local sig="${1:-TERM}"
        echo -n "Sending $sig to remaining processes ... "
-       top -bn1 | while read pid ppid user stat vsz pvsz pcpu cmd args; do
+       /bin/busybox top -bn1 2>/dev/null | while read pid ppid user stat vsz pvsz pcpu cmd args; do
                case "$pid" in
                        [0-9]*) : ;;
                        *) continue ;;