ar71xx: TL-MR3020: fix board detection, fix missing mandatory package and modify...
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 25 Jan 2012 07:44:45 +0000 (07:44 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 25 Jan 2012 07:44:45 +0000 (07:44 +0000)
This patch fixes the board detection of the TL-MR3020.

The LED behaviour has also been modified:
* The WPS LED is the diag LED now.
* A netdev trigger for the LAN LED has been added.

The profile of the TL-MR3020 has been updated because the needed package
"kmod-ledtrig-usbdev" was missing which resulted in a non-working usbdev
trigger for the 3G/USB LED.

[juhosg: the board name changes has been removed, and the kernel files
has been changed instead.]

Signed-off-by: Christian Cier-Zniewski <c.cier@gmx.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29905 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/base-files/etc/diag.sh
target/linux/ar71xx/base-files/etc/uci-defaults/leds
target/linux/ar71xx/files-2.6.39/arch/mips/ar71xx/mach-tl-mr3020.c
target/linux/ar71xx/files-3.2/arch/mips/ath79/mach-tl-mr3020.c
target/linux/ar71xx/generic/profiles/tp-link.mk

index 76f263b..f30ad05 100755 (executable)
@@ -97,7 +97,9 @@ get_status_led() {
        tew-632brp)
                status_led="tew-632brp:green:status"
                ;;
-       tl-mr3020 | \
+       tl-mr3020)
+               status_led="tp-link:green:wps"
+               ;;
        tl-mr3220 | \
        tl-mr3420 | \
        tl-wa901nd | \
index 45be6bd..f65af4a 100755 (executable)
@@ -146,6 +146,7 @@ om2p)
 tl-mr3020)
        set_led_usbdev "usb" "USB" "tp-link:green:3g" "1-1"
        set_led_wlan "wlan" "WLAN" "tp-link:green:wlan" "phy0tpt"
+       set_led_netdev "lan" "LAN" "tp-link:green:lan"  "eth0"
        ;;
 
 tl-mr3220 | \
index 21ec3e0..cccb4d4 100644 (file)
@@ -118,5 +118,5 @@ static void __init tl_mr3020_setup(void)
        ar9xxx_add_device_wmac(ee, mac);
 }
 
-MIPS_MACHINE(AR71XX_MACH_TL_MR3020, "TL-MR3020", "TP-LINK TL-MR3020 v1",
+MIPS_MACHINE(AR71XX_MACH_TL_MR3020, "TL-MR3020", "TP-LINK TL-MR3020",
             tl_mr3020_setup);
index 35be0f7..9732d5c 100644 (file)
@@ -117,5 +117,5 @@ static void __init tl_mr3020_setup(void)
        ath79_register_wmac(ee, mac);
 }
 
-MIPS_MACHINE(ATH79_MACH_TL_MR3020, "TL-MR3020", "TP-LINK TL-MR3020 v1",
+MIPS_MACHINE(ATH79_MACH_TL_MR3020, "TL-MR3020", "TP-LINK TL-MR3020",
             tl_mr3020_setup);
index 8f1314a..e927696 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/TLMR3020
        NAME:=TP-LINK TL-MR3020
-       PACKAGES:=kmod-usb-core kmod-usb2
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
 endef
 
 define Profile/TLMR3020/Description