kirkwood: Seagate GoFlex Net
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 12 Feb 2015 14:39:26 +0000 (14:39 +0000)
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 12 Feb 2015 14:39:26 +0000 (14:39 +0000)
Add GoFlex Net "Board Name" , set and cleanup network default and LEDs.
Remove kmod-rtc-marvell from default packages, as the GoFlex net does not have a RTC.

Signed-off-by: L. D. Pinney <ldpinney@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44422 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/kirkwood/base-files/etc/diag.sh [changed mode: 0644->0755]
target/linux/kirkwood/base-files/etc/uci-defaults/01_leds
target/linux/kirkwood/base-files/etc/uci-defaults/02_network
target/linux/kirkwood/base-files/lib/kirkwood.sh
target/linux/kirkwood/profiles/110-nas.mk

old mode 100644 (file)
new mode 100755 (executable)
index b2bb583..29445d5
@@ -6,6 +6,11 @@
 
 get_status_led() {
        case $(kirkwood_board_name) in
+       dockstar|\
+       goflexnet|\
+       pogo_e02)
+               status_led="status:orange:fault"
+               ;;
        ea4500)
                status_led="ea4500:white:health"
                ;;
index ba4d569..0f7a906 100644 (file)
@@ -20,6 +20,10 @@ case "$board" in
        ucidef_set_led_default "health" "health" "ea4500:white:health" "1"
        ucidef_set_led_default "pulse" "pulse" "ea4500:white:pulse" "1"
        ;;
+"goflexnet")
+        ucidef_set_led_default "health" "health" "status:green:health" "1"
+        ucidef_set_led_default "fault" "fault" "status:orange:fault" "0"
+       ;;
 "ib62x0")
        ucidef_set_led_default "health" "health" "ib62x0:green:os" "1"
        ucidef_set_led_default "fault" "fault" "ib62x0:red:os" "1"
index 540c8c3..4ed0ab4 100644 (file)
@@ -28,15 +28,10 @@ board=$(kirkwood_board_name)
 ucidef_set_interface_loopback
 
 case "$board" in
-"dockstar")
-       set_lan_dhcp "eth0"
-       ;;
-"iconnect")
-       set_lan_dhcp "eth0"
-       ;;
-"ib62x0")
-       set_lan_dhcp "eth0"
-       ;;
+"dockstar"|\
+"goflexnet"|\
+"iconnect"|\
+"ib62x0"|\
 "pogo_e02")
        set_lan_dhcp "eth0"
        ;;
index 962b09a..c088581 100755 (executable)
@@ -17,6 +17,10 @@ kirkwood_board_detect() {
                name="dockstar"
                ;;
 
+       "Seagate GoFlex Net")
+               name="goflexnet"
+               ;;
+
        "Iomega Iconnect")
                name="iconnect"
                ;;
index 7b8d7bc..66a4f6c 100644 (file)
@@ -25,7 +25,7 @@ define Profile/GOFLEXNET
   NAME:=Seagate GoFlexNet
   PACKAGES:= \
        kmod-ata-core kmod-ata-marvell-sata \
-       kmod-rtc-marvell kmod-usb2 kmod-usb-storage \
+       kmod-usb2 kmod-usb-storage \
        uboot-envtools
 endef