[ar7] push atm, br2684ctl and kmod-pppoa down the DSL Profile
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 16 Nov 2012 13:00:48 +0000 (13:00 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 16 Nov 2012 13:00:48 +0000 (13:00 +0000)
Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34206 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar7/Makefile
target/linux/ar7/generic/profiles/100-Annex-A.mk
target/linux/ar7/generic/profiles/110-Annex-B.mk

index ead26d9..3d34c41 100644 (file)
@@ -17,8 +17,7 @@ LINUX_VERSION:=3.3.8
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES+= kmod-pppoa ppp-mod-pppoa linux-atm atm-tools br2684ctl \
-               kmod-acx-mac80211 swconfig wpad-mini
+DEFAULT_PACKAGES+= kmod-acx-mac80211 swconfig wpad-mini
 
 define Target/Description
        Build firmware images for TI AR7 based routers.
index 3d74b5d..d8e549e 100644 (file)
@@ -7,7 +7,8 @@
 
 define Profile/Annex-A
   NAME:=Annex-A DSL firmware (default)
-  PACKAGES:=kmod-sangam-atm-annex-a
+  PACKAGES:=kmod-pppoa ppp-mod-pppoa linux-atm atm-tools br2684ctl \
+           kmod-sangam-atm-annex-a
 endef
 
 define Profile/Annex-A/Description
index 66692e7..55de1fc 100644 (file)
@@ -7,7 +7,8 @@
 
 define Profile/Annex-B
   NAME:=Annex-B DSL firmware
-  PACKAGES:=kmod-sangam-atm-annex-b
+  PACKAGES:=kmod-pppoa ppp-mod-pppoa linux-atm atm-tools br2684ctl \
+           kmod-sangam-atm-annex-b
 endef
 
 define Profile/Annex-B/Description