[uboot-lantiq]
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 11 Mar 2011 08:22:47 +0000 (08:22 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 11 Mar 2011 08:22:47 +0000 (08:22 +0000)
* add some compile flags

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26025 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/uboot-lantiq/patches/010-fix-mips-flags.patch

index 4c706a7..6dd7d8f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/cpu/mips/config.mk
 +++ b/cpu/mips/config.mk
-@@ -23,16 +23,18 @@
+@@ -23,17 +23,19 @@
  v=$(shell $(AS) --version | grep 'GNU assembler' | egrep -o '2\.[0-9\.]+' | cut -d. -f2)
  MIPSFLAGS:=$(shell \
  if [ "$v" -lt "14" ]; then \
@@ -19,5 +19,7 @@
  endif
 +endif
  
- MIPSFLAGS += $(ENDIANNESS)
+-MIPSFLAGS += $(ENDIANNESS)
++MIPSFLAGS += $(ENDIANNESS) -fno-schedule-insns -fno-schedule-insns2
  
+ PLATFORM_CPPFLAGS += $(MIPSFLAGS)