mvebu: copy the initramfs files to the bin dir
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 13 Apr 2015 20:06:47 +0000 (20:06 +0000)
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 13 Apr 2015 20:06:47 +0000 (20:06 +0000)
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45421 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/mvebu/image/Makefile

index 0d75e30..e6e7529 100644 (file)
@@ -14,8 +14,6 @@ JFFS2_BLOCKSIZE = 128k
 KDIR_TMP:=$(KDIR)/tmp
 
 
-UIMAGE:=$(BIN_DIR)/$(IMG_PREFIX)-uImage
-
 define Image/Build/DTB
        cp $(KDIR)/zImage$(2) $(KDIR)/zImage$(2)-$(1);
        cat $(DTS_DIR)/$(1).dtb >> $(KDIR)/zImage$(2)-$(1);
@@ -44,6 +42,7 @@ define NANDProfile
 
   define Image/Build/Profile/$(1)/Initramfs
        $(call Image/Build/DTB,$(2),-initramfs)
+       cp $(KDIR)/uImage-initramfs-$(2) $(BIN_DIR)/$(IMG_PREFIX)-$(2)-initramfs
   endef
 
   define Image/Build/Profile/$(1)/squashfs