libiconv-full: fix build with fortify source
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 25 Jun 2015 12:13:57 +0000 (12:13 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 25 Jun 2015 12:13:57 +0000 (12:13 +0000)
Avoid redefining `realpath` to fix the following error:

    .../include/fortify/stdlib.h:36:13: error: 'realpath' undeclared here (not in a function)

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46127 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/libs/libiconv-full/Makefile
package/libs/libiconv-full/patches/300-fortify-source-compat.patch [new file with mode: 0644]

index 75bca83..997cce2 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libiconv-full
 PKG_VERSION:=1.11.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
 
diff --git a/package/libs/libiconv-full/patches/300-fortify-source-compat.patch b/package/libs/libiconv-full/patches/300-fortify-source-compat.patch
new file mode 100644 (file)
index 0000000..e7e9223
--- /dev/null
@@ -0,0 +1,23 @@
+--- a/m4/canonicalize.m4
++++ b/m4/canonicalize.m4
+@@ -11,8 +11,6 @@ AC_DEFUN([gl_CANONICALIZE],
+   AC_CHECK_FUNCS(canonicalize_file_name)
+   if test $ac_cv_func_canonicalize_file_name = no; then
+     AC_LIBOBJ(canonicalize)
+-    AC_DEFINE([realpath], [rpl_realpath],
+-      [Define to a replacement function name for realpath().])
+     gl_PREREQ_CANONICALIZE
+   fi
+ ])
+--- a/configure
++++ b/configure
+@@ -35532,9 +35532,6 @@ done
+   if test $ac_cv_func_canonicalize_file_name = no; then
+     SRCLIBOBJS="$SRCLIBOBJS canonicalize.$ac_objext"
+-cat >>confdefs.h <<\_ACEOF
+-#define realpath rpl_realpath
+-_ACEOF