set TOOLCHAIN_DIR var when using external toolchain
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 2 Apr 2011 14:27:51 +0000 (14:27 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 2 Apr 2011 14:27:51 +0000 (14:27 +0000)
This patch allows to use the openwrt toolchain as external toolchain for the
same project. See bug #9131 for details.

Signed-off-by: Sven Bachmann <dev@mcbachmann.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26405 3c298f89-4303-0410-b956-a3cf2f4a3e73

rules.mk

index 428258f..a3516a5 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -140,6 +140,7 @@ ifndef DUMP
       ifneq ($(TOOLCHAIN_LIB_DIRS),)
         TARGET_LDFLAGS+= $(patsubst %,-L%,$(TOOLCHAIN_LIB_DIRS))
       endif
+      TOOLCHAIN_DIR:=$(TOOLCHAIN_ROOT_DIR)
     endif
   endif
 endif