fix download url, add target optimization cflags, ipkg/conffiles,
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 14 Dec 2005 19:09:22 +0000 (19:09 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 14 Dec 2005 19:09:22 +0000 (19:09 +0000)
add Id tag to the Makefile.

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2671 3c298f89-4303-0410-b956-a3cf2f4a3e73

openwrt/package/l2tpns/Makefile [changed mode: 0755->0644]
openwrt/package/l2tpns/ipkg/l2tpns.conffiles [new file with mode: 0644]
openwrt/package/l2tpns/ipkg/l2tpns.control [changed mode: 0755->0644]

old mode 100755 (executable)
new mode 100644 (file)
index 6f2406e..e138f51
@@ -1,14 +1,17 @@
+# $Id$
+
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=l2tpns
 PKG_VERSION:=2.1.14
 PKG_RELEASE:=1
 PKG_MD5SUM:=2a0ee2a3678160c335f1d68c17c4f871
-PKG_SOURCE_URL:=@SF/L2TPNS
+
+PKG_SOURCE_URL:=@SF/l2tpns
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_CAT:=zcat
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(TOPDIR)/package/rules.mk
@@ -19,11 +22,21 @@ $(PKG_BUILD_DIR)/.configured:
        touch $@
 
 $(PKG_BUILD_DIR)/.built:
-       $(MAKE) CC=$(TARGET_CC) LD=$(TARGET_CC) DESTDIR=$(PKG_INSTALL_DIR) STAGING_DIR=$(STAGING_DIR) -C $(PKG_BUILD_DIR) install
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC=$(TARGET_CC) \
+               LD=$(TARGET_CC) \
+               OPTIM="$(TARGET_CFLAGS)" \
+               DESTDIR=$(PKG_INSTALL_DIR) \
+               STAGING_DIR=$(STAGING_DIR) \
+               all install
        touch $@
 
 $(IPKG_L2TPNS):
-       mkdir -p $(IDIR_L2TPNS)
-       cp -fpR $(PKG_INSTALL_DIR)/* $(IDIR_L2TPNS)/
+       install -d -m0755 $(IDIR_L2TPNS)/etc/l2tpns
+       cp -fpR $(PKG_INSTALL_DIR)/etc/l2tpns/* $(IDIR_L2TPNS)/etc/l2tpns/
+       install -d -m0755 $(IDIR_L2TPNS)/usr/lib/l2tpns
+       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/l2tpns/* $(IDIR_L2TPNS)/usr/lib/l2tpns/
+       install -d -m0755 $(IDIR_L2TPNS)/usr/sbin
+       cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/* $(IDIR_L2TPNS)/usr/sbin/
        $(RSTRIP) $(IDIR_L2TPNS)
        $(IPKG_BUILD) $(IDIR_L2TPNS) $(PACKAGE_DIR)
diff --git a/openwrt/package/l2tpns/ipkg/l2tpns.conffiles b/openwrt/package/l2tpns/ipkg/l2tpns.conffiles
new file mode 100644 (file)
index 0000000..eaf3a50
--- /dev/null
@@ -0,0 +1,3 @@
+/etc/l2tpns/ip_pool
+/etc/l2tpns/startup-config
+/etc/l2tpns/users
old mode 100755 (executable)
new mode 100644 (file)
index 6928c2e..1946f88
@@ -1,5 +1,4 @@
 Package: l2tpns
 Section: net
-Architecture: mipsel
 Priority: optional
-Description: l2tpns is a layer 2 tunneling protocol network server (LNS). It supports up to 65535 concurrent sessions per server/cluster plus ISP features such as rate limiting, walled garden, usage accounting, and more.
\ No newline at end of file
+Description: A layer 2 tunneling protocol network server (LNS).