include, base-files: align default repository url with changed buildbot structure
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 23 Jan 2015 13:09:54 +0000 (13:09 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 23 Jan 2015 13:09:54 +0000 (13:09 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44091 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/version.mk
package/base-files/image-config.in

index c4747f2..c3cc170 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2012 OpenWrt.org
+# Copyright (C) 2012-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -30,7 +30,7 @@ VERSION_NICK:=$(call qstrip_escape,$(CONFIG_VERSION_NICK))
 VERSION_NICK:=$(if $(VERSION_NICK),$(VERSION_NICK),$(RELEASE))
 
 VERSION_REPO:=$(call qstrip_escape,$(CONFIG_VERSION_REPO))
-VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),http://downloads.openwrt.org/snapshots/trunk/%T/packages)
+VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),http://downloads.openwrt.org/snapshots/trunk/%S/packages)
 
 VERSION_DIST:=$(call qstrip_escape,$(CONFIG_VERSION_DIST))
 VERSION_DIST:=$(if $(VERSION_DIST),$(VERSION_DIST),OpenWrt)
index 193ea08..fd0ead6 100644 (file)
@@ -170,7 +170,7 @@ if VERSIONOPT
        config VERSION_REPO
                string
                prompt "Release repository"
-               default "http://downloads.openwrt.org/snapshots/trunk/%s/packages"
+               default "http://downloads.openwrt.org/snapshots/trunk/%S/packages"
                help
                        This is the repository address embedded in the image, it defaults
                        to the trunk snapshot repo; the url may contain the following placeholders:
@@ -185,7 +185,6 @@ if VERSIONOPT
                         %d .. Distribution name or "openwrt", lowercase
                         %T .. Target name
                         %S .. Target/Subtarget name
-                        %s .. Target/Subtarget name in dotted notation, e.g. "ar71xx" or "ar71xx.nand"
                         %t .. Build taint flags, e.g. "no-all busybox"
                         %M .. Manufacturer name or "OpenWrt"
                         %P .. Product name or "Generic"