flex: fix build error due to undefined library symbols
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 12 Mar 2014 10:47:31 +0000 (10:47 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 12 Mar 2014 10:47:31 +0000 (10:47 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39888 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/Makefile
tools/flex/patches/100-remove_no_undefined.patch [new file with mode: 0644]

index 7466b82..428cf0b 100644 (file)
@@ -41,7 +41,7 @@ tools-$(BUILD_PPL_CLOOG) += ppl cloog
 
 # builddir dependencies
 $(curdir)/bison/compile := $(curdir)/flex/install
-$(curdir)/flex/compile := $(curdir)/m4/install
+$(curdir)/flex/compile := $(curdir)/automake/install
 $(curdir)/pkg-config/compile := $(curdir)/sed/install
 $(curdir)/libtool/compile := $(curdir)/sed/install
 $(curdir)/squashfs/compile := $(curdir)/lzma-old/install
diff --git a/tools/flex/patches/100-remove_no_undefined.patch b/tools/flex/patches/100-remove_no_undefined.patch
new file mode 100644 (file)
index 0000000..4e8aca1
--- /dev/null
@@ -0,0 +1,18 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -73,13 +73,13 @@ libfl_la_SOURCES = \
+       libmain.c \
+       libyywrap.c
+-libfl_la_LDFLAGS = -no-undefined -version-info @SHARED_VERSION_INFO@
++libfl_la_LDFLAGS = -version-info @SHARED_VERSION_INFO@
+ libfl_pic_la_SOURCES = \
+       libmain.c \
+       libyywrap.c
+-libfl_pic_la_LDFLAGS = -no-undefined -version-info @SHARED_VERSION_INFO@
++libfl_pic_la_LDFLAGS = -version-info @SHARED_VERSION_INFO@
+ noinst_HEADERS = \
+       flexdef.h \