build: do not call initramfs build from within the image builder
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 29 May 2015 13:41:31 +0000 (13:41 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 29 May 2015 13:41:31 +0000 (13:41 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45837 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/image.mk

index 051f0f7..36c6c63 100644 (file)
@@ -471,7 +471,7 @@ define BuildImage
 
   kernel_prepare: mkfs_prepare
        $(call Image/BuildKernel)
-       $(if $(CONFIG_TARGET_ROOTFS_INITRAMFS),$(call Image/BuildKernel/Initramfs))
+       $(if $(CONFIG_TARGET_ROOTFS_INITRAMFS),$(if $(IB),,$(call Image/BuildKernel/Initramfs)))
        $(call Image/InstallKernel)
 
   $(foreach device,$(TARGET_DEVICES),$(call Device,$(device)))