[include] prereq-build.mk: do not perform static linking tests on Darwin
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 12 Aug 2012 12:34:28 +0000 (12:34 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 12 Aug 2012 12:34:28 +0000 (12:34 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33139 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/prereq-build.mk

index 74f1e32..c7d59f1 100644 (file)
@@ -8,6 +8,7 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/prereq.mk
 include $(INCLUDE_DIR)/host.mk
+include $(INCLUDE_DIR)/host-build.mk
 
 PKG_NAME:=Build dependency
 
@@ -70,24 +71,26 @@ $(eval $(call Require,working-g++, \
        Please install the GNU C++ Compiler (g++). \
 ))
 
-define Require/working-gcc-static
+ifneq ($(HOST_STATIC_LINKING),)
+  define Require/working-gcc-static
        echo 'int main(int argc, char **argv) { return 0; }' | \
-               gcc -x c -static -o $(TMP_DIR)/a.out -
-endef
+               gcc -x c $(HOST_STATIC_LINKING) -o $(TMP_DIR)/a.out -
+  endef
 
-$(eval $(call Require,working-gcc-static, \
+  $(eval $(call Require,working-gcc-static, \
     Please install the static libc development package (glibc-static on CentOS/Fedora/RHEL). \
-))
+  ))
 
-define Require/working-g++-static
+  define Require/working-g++-static
        echo 'int main(int argc, char **argv) { return 0; }' | \
-               g++ -x c++ -static -o $(TMP_DIR)/a.out - -lstdc++ && \
+               g++ -x c++ $(HOST_STATIC_LINKING) -o $(TMP_DIR)/a.out - -lstdc++ && \
                $(TMP_DIR)/a.out
-endef
+  endef
 
-$(eval $(call Require,working-g++-static, \
+  $(eval $(call Require,working-g++-static, \
        Please install the static libstdc++ development package (libstdc++-static on CentOS/Fedora/RHEL). \
-))
+  ))
+endif
 
 define Require/ncurses
        echo 'int main(int argc, char **argv) { initscr(); return 0; }' | \
@@ -108,14 +111,16 @@ $(eval $(call Require,zlib, \
        Please install zlib. (Missing libz.so or zlib.h) \
 ))
 
-define Require/zlib-static
+ifneq ($(HOST_STATIC_LINKING),)
+  define Require/zlib-static
        echo 'int main(int argc, char **argv) { gzdopen(0, "rb"); return 0; }' | \
-               gcc -include zlib.h -x c -static -o $(TMP_DIR)/a.out - -lz
-endef
+               gcc -include zlib.h -x c $(HOST_STATIC_LINKING) -o $(TMP_DIR)/a.out - -lz
+  endef
 
-$(eval $(call Require,zlib-static, \
+  $(eval $(call Require,zlib-static, \
        Please install a static zlib. (zlib-static on CentOS/Fedora/RHEL). \
-))
+  ))
+endif
 
 $(eval $(call RequireCommand,gawk, \
        Please install GNU awk. \