uci: update to 2010-09-28
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 14 Oct 2010 00:14:30 +0000 (00:14 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 14 Oct 2010 00:14:30 +0000 (00:14 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23430 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/uci/Makefile
package/uci/patches/120-uci_trigger.patch

index 3c88dae..394fdf7 100644 (file)
@@ -7,13 +7,13 @@
 
 include $(TOPDIR)/rules.mk
 
-UCI_VERSION=12012009
-UCI_RELEASE=6
+UCI_VERSION=2010-09-28
+UCI_RELEASE=1
 
 PKG_NAME:=uci
 PKG_VERSION:=$(UCI_VERSION)$(if $(UCI_RELEASE),.$(UCI_RELEASE))
 PKG_RELEASE:=2
-PKG_REV:=aa3ab8012bfbf793d2884c08ea924545a04e9544
+PKG_REV:=3fa65a20ae0fc77b951515bc5de7a0041adc9be1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=git://nbd.name/uci.git
index a1454a3..03c3760 100644 (file)
@@ -65,7 +65,7 @@
 +
 +struct trigger_set_op {
 +      struct uci_package *p;
-+      struct uci_history *h;
++      struct uci_delta *h;
 +};
 +
 +static int trigger_set(lua_State *L)
@@ -73,7 +73,7 @@
 +      struct trigger_set_op *so =
 +              (struct trigger_set_op *)lua_touserdata(L, 1);
 +      struct uci_package *p = so->p;
-+      struct uci_history *h = so->h;
++      struct uci_delta *h = so->h;
 +      struct uci_context *ctx = p->ctx;
 +
 +      /* ignore non-standard savedirs/configdirs
 +
 +#endif
 +
-+static void trigger_set_hook(const struct uci_hook_ops *ops, struct uci_package *p, struct uci_history *h)
++static void trigger_set_hook(const struct uci_hook_ops *ops, struct uci_package *p, struct uci_delta *h)
 +{
 +      struct trigger_set_op so;
 +