[package] kernel: fix packaging of 8250.ko with Linux 3.x
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 25 Apr 2012 13:43:15 +0000 (13:43 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 25 Apr 2012 13:43:15 +0000 (13:43 +0000)
This commit fixes build breakage in package/kernel leading to missing
subsequent kmods like kmod-usb-serial, this should fix the missing
packages in ar71xx builds.

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31477 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/other.mk

index abac481..d3450cf 100644 (file)
@@ -896,7 +896,15 @@ define KernelPackage/serial-8250
        CONFIG_SERIAL_8250_SHARE_IRQ=y \
        CONFIG_SERIAL_8250_DETECT_IRQ=n \
        CONFIG_SERIAL_8250_RSA=n
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.3)),1)
+  FILES:=$(LINUX_DIR)/drivers/tty/serial/8250/8250.ko
+else
+ ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.38)),1)
   FILES:=$(LINUX_DIR)/drivers/tty/serial/8250.ko
+ else
+  FILES:=$(LINUX_DIR)/drivers/serial/8250.ko
+ endif
+endif
 endef
 
 define KernelPackage/serial-8250/description