[package] base-files: if an ip6addr without a prefix is given, assume /128 - otherwis...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 9 Jun 2011 12:25:48 +0000 (12:25 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 9 Jun 2011 12:25:48 +0000 (12:25 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27145 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/base-files/Makefile
package/base-files/files/lib/network/config.sh

index 2ad6bdd..23bd51a 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=72
+PKG_RELEASE:=73
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
index 7e4a53d..76ba324 100755 (executable)
@@ -235,6 +235,11 @@ setup_interface_static() {
        config_get bcast "$config" broadcast
        config_get metric "$config" metric
 
+       case "$ip6addr" in
+               */*) ;;
+               *:*) ip6addr="$ip6addr/128" ;;
+       esac
+
        [ -z "$ipaddr" ] || $DEBUG ifconfig "$iface" "$ipaddr" netmask "$netmask" broadcast "${bcast:-+}"
        [ -z "$ip6addr" ] || $DEBUG ifconfig "$iface" add "$ip6addr"
        [ -z "$gateway" ] || $DEBUG route add default gw "$gateway" ${metric:+metric $metric} dev "$iface"