add util-linux
[openwrt.git] / package / util-linux / Makefile
index 7eb1801..ef28bdb 100644 (file)
@@ -1,37 +1,47 @@
-# $Id$
+# $Id: Makefile 3822 2006-05-24 07:01:52Z nico $
 
 include $(TOPDIR)/rules.mk
 
-PKG_NAME:=fdisk
+PKG_NAME:=util-linux
 PKG_VERSION:=2.12r
 PKG_RELEASE:=1
 PKG_MD5SUM:=c261230b27fc0fbcc287c76884caf2d3
 
-PKG_SOURCE_URL:=ftp://ftp.kernel.org/pub/linux/utils/util-linux/ \
-       http://ftp.kernel.org/pub/linux/utils/util-linux/ \
-       ftp://ftp.de.kernel.org/pub/linux/utils/util-linux/ \
-       http://ftp.de.kernel.org/pub/linux/utils/util-linux/
-PKG_SOURCE:=util-linux-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=ftp://ftp.kernel.org/pub/linux/utils/$(PKG_NAME)/ \
+       http://ftp.kernel.org/pub/linux/utils/$(PKG_NAME)/ \
+       ftp://ftp.de.kernel.org/pub/linux/utils/$(PKG_NAME)/ \
+       http://ftp.de.kernel.org/pub/linux/utils/$(PKG_NAME)/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_CAT:=zcat
-PKG_BUILD_DIR:=$(BUILD_DIR)/util-linux-$(PKG_VERSION)
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(TOPDIR)/package/rules.mk
 
-$(eval $(call PKG_template,FDISK,fdisk,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,LOSETUP,losetup,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,SWAP_UTILS,swap-utils,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+define Package/fdisk
+SECTION:=base
+CATEGORY:=Utilities
+TITLE:=Partition table manipulation utility
+DESCRIPTION:=A partition table manipulation utility
+URL:=http://www.kernel.org/pub/linux/utils/util-linux/
+endef
 
-$(PKG_BUILD_DIR)/.configured:
-       (cd $(PKG_BUILD_DIR); \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-               ./configure \
-       );
-       touch $@
+define Package/losetup
+$(call Package/fdisk)
+TITLE:=Loopback devices setup and control utility
+DESCRIPTION:=A loopback devices setup and control utility
+endef
+
+define Package/swap-utils
+$(call Package/fdisk)
+TITLE:=Swap space management utilities
+DESCRIPTION:=A collection of tools to manage swap space \\\
+    * mkswap\\\
+    * swapon\\\
+    * swapoff
+endef
 
-$(PKG_BUILD_DIR)/.built:
+define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
@@ -40,27 +50,28 @@ $(PKG_BUILD_DIR)/.built:
                DESTDIR="$(PKG_INSTALL_DIR)" \
                INSTALLSUID="install -m 4755" \
                all install
-       touch $@
-
-$(IPKG_FDISK):
-       install -d -m0755 $(IDIR_FDISK)/usr/sbin
-       cp -fpR $(PKG_INSTALL_DIR)/sbin/fdisk $(IDIR_FDISK)/usr/sbin/
-       $(RSTRIP) $(IDIR_FDISK)
-       $(IPKG_BUILD) $(IDIR_FDISK) $(PACKAGE_DIR)
-
-$(IPKG_LOSETUP):
-       install -d -m0755 $(IDIR_LOSETUP)/usr/sbin
-       cp -fpR $(PKG_INSTALL_DIR)/sbin/losetup $(IDIR_LOSETUP)/usr/sbin/
-       $(RSTRIP) $(IDIR_LOSETUP)
-       $(IPKG_BUILD) $(IDIR_LOSETUP) $(PACKAGE_DIR)
+endef
 
-$(IPKG_SWAP_UTILS):
-       install -d -m0755 $(IDIR_SWAP_UTILS)/usr/sbin
-       cp -fpR $(PKG_INSTALL_DIR)/sbin/mkswap $(IDIR_SWAP_UTILS)/usr/sbin/
-       cp -fpR $(PKG_INSTALL_DIR)/sbin/swap{on,off} $(IDIR_SWAP_UTILS)/usr/sbin/
-       $(RSTRIP) $(IDIR_SWAP_UTILS)
-       $(IPKG_BUILD) $(IDIR_SWAP_UTILS) $(PACKAGE_DIR)
+define Package/Template
+       @if [ \! -f "$(PKG_INSTALL_DIR)/$(1)" ]; then \
+               rm -f $(PKG_BUILD_DIR)/.built; \
+               $(MAKE) $(PKG_BUILD_DIR)/.built; \
+       fi
+       install -d -m0755 $(2)
+       $(CP) $(PKG_INSTALL_DIR)/$(1) $(2)/
+endef
 
-mostlyclean:
-       -$(MAKE) -C $(PKG_BUILD_DIR) clean
-       rm -f $(PKG_BUILD_DIR)/.built
+define Package/fdisk/install
+       $(call Package/Template,sbin/fdisk,$(1)/usr/sbin)
+endef
+define Package/losetup/install
+       $(call Package/Template,sbin/losetup,$(1)/usr/sbin)
+endef
+define Package/swap-utils/install
+       $(call Package/Template,sbin/mkswap,$(1)/usr/sbin)
+       $(call Package/Template,sbin/swapon,$(1)/usr/sbin)
+       $(call Package/Template,sbin/swapoff,$(1)/usr/sbin)
+endef
+$(eval $(call BuildPackage,fdisk))
+$(eval $(call BuildPackage,losetup))
+$(eval $(call BuildPackage,swap-utils))