add util-linux
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 18 Jun 2006 19:16:08 +0000 (19:16 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 18 Jun 2006 19:16:08 +0000 (19:16 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4000 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/util-linux/Makefile [new file with mode: 0644]
package/util-linux/patches/501-mconfig.patch [new file with mode: 0644]

diff --git a/package/util-linux/Makefile b/package/util-linux/Makefile
new file mode 100644 (file)
index 0000000..ef28bdb
--- /dev/null
@@ -0,0 +1,77 @@
+# $Id: Makefile 3822 2006-05-24 07:01:52Z nico $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=util-linux
+PKG_VERSION:=2.12r
+PKG_RELEASE:=1
+PKG_MD5SUM:=c261230b27fc0fbcc287c76884caf2d3
+
+PKG_SOURCE_URL:=ftp://ftp.kernel.org/pub/linux/utils/$(PKG_NAME)/ \
+       http://ftp.kernel.org/pub/linux/utils/$(PKG_NAME)/ \
+       ftp://ftp.de.kernel.org/pub/linux/utils/$(PKG_NAME)/ \
+       http://ftp.de.kernel.org/pub/linux/utils/$(PKG_NAME)/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+define Package/fdisk
+SECTION:=base
+CATEGORY:=Utilities
+TITLE:=Partition table manipulation utility
+DESCRIPTION:=A partition table manipulation utility
+URL:=http://www.kernel.org/pub/linux/utils/util-linux/
+endef
+
+define Package/losetup
+$(call Package/fdisk)
+TITLE:=Loopback devices setup and control utility
+DESCRIPTION:=A loopback devices setup and control utility
+endef
+
+define Package/swap-utils
+$(call Package/fdisk)
+TITLE:=Swap space management utilities
+DESCRIPTION:=A collection of tools to manage swap space \\\
+    * mkswap\\\
+    * swapon\\\
+    * swapoff
+endef
+
+define Build/Compile
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               $(TARGET_CONFIGURE_OPTS) \
+               OPT="$(TARGET_CFLAGS)" \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               INSTALLSUID="install -m 4755" \
+               all install
+endef
+
+define Package/Template
+       @if [ \! -f "$(PKG_INSTALL_DIR)/$(1)" ]; then \
+               rm -f $(PKG_BUILD_DIR)/.built; \
+               $(MAKE) $(PKG_BUILD_DIR)/.built; \
+       fi
+       install -d -m0755 $(2)
+       $(CP) $(PKG_INSTALL_DIR)/$(1) $(2)/
+endef
+
+define Package/fdisk/install
+       $(call Package/Template,sbin/fdisk,$(1)/usr/sbin)
+endef
+define Package/losetup/install
+       $(call Package/Template,sbin/losetup,$(1)/usr/sbin)
+endef
+define Package/swap-utils/install
+       $(call Package/Template,sbin/mkswap,$(1)/usr/sbin)
+       $(call Package/Template,sbin/swapon,$(1)/usr/sbin)
+       $(call Package/Template,sbin/swapoff,$(1)/usr/sbin)
+endef
+$(eval $(call BuildPackage,fdisk))
+$(eval $(call BuildPackage,losetup))
+$(eval $(call BuildPackage,swap-utils))
diff --git a/package/util-linux/patches/501-mconfig.patch b/package/util-linux/patches/501-mconfig.patch
new file mode 100644 (file)
index 0000000..67e6530
--- /dev/null
@@ -0,0 +1,68 @@
+--- util-linux-2.12r-orig/MCONFIG      2004-12-13 00:15:48.000000000 +0100
++++ util-linux-2.12r/MCONFIG   2005-10-03 17:54:15.945049312 +0200
+@@ -16,8 +16,8 @@
+ # Select for ARCH one of intel, alpha, sparc, arm, m68k, mips
+ # Select for CPU i386 if the binaries must be able to run on an intel 386
+ # (by default i486 code is generated, see below)
+-CPU=$(shell uname -m)
+-ARCH=$(shell echo $(CPU) | sed 's/i.86/intel/;s/arm.*/arm/')
++CPU=
++ARCH=mips
+ # If HAVE_PAM is set to "yes", then login, chfn, chsh, and newgrp
+ # will use PAM for authentication. Additionally, passwd will not be
+@@ -64,12 +64,12 @@
+ # If HAVE_WRITE is set to "yes", then write will not be built or
+ # installed from the misc-utils subdirectory.
+ # (There is a network aware write in netwrite from NetKit 0.16 or later.)
+-HAVE_WRITE=no
++HAVE_WRITE=yes
+ # If HAVE_GETTY is set to "yes", then agetty will not be built or
+ # installed from the login-utils subdirectory.  Note that agetty can
+ # co-exist with other gettys, so this option should never be used.
+-HAVE_GETTY=no
++HAVE_GETTY=yes
+ # If USE_TTY_GROUP is set to "yes", then wall and write will be installed
+ # setgid to the "tty" group, and mesg will only set the group write bit.
+@@ -82,13 +82,13 @@
+ # If HAVE_KILL is set to "yes", then kill will not be built or
+ # installed from the misc-utils subdirectory.
+ # (There is also a kill in the procps package.)
+-HAVE_KILL=no
++HAVE_KILL=yes
+ # If ALLOW_VCS_USE is set to "yes", then login will chown /dev/vcsN
+ # to the current user, allowing her to make a screendump and do other
+ # nifty things on the console, but also allowing him to keep an open
+ # file descriptor after logging out to trick the next user.
+-ALLOW_VCS_USE=yes
++ALLOW_VCS_USE=no
+ # If DO_STAT_MAIL is set to "yes", then login will stat() the mailbox
+ # and tell the user that she has new mail. This can hang the login if
+@@ -102,19 +102,19 @@
+ # If HAVE_SLN is set to "yes", then sln won't be installed
+ # (but the man page sln.8 will be installed anyway).
+ # sln also comes with libc and glibc.
+-HAVE_SLN=no
++HAVE_SLN=yes
+ # If HAVE_FDUTILS is set to "yes", then setfdprm won't be installed.
+-HAVE_FDUTILS=no
++HAVE_FDUTILS=yes
+ # If SILENT_PG is set to "yes", then pg will not ring the bell
+ # when an invalid key is pressed
+-SILENT_PG=no
++SILENT_PG=yes
+ # If configure decides that Native Language Support (NLS) is available,
+ # it sets MAY_ENABLE_NLS in defines.h. If you don't want NLS, set
+ # DISABLE_NLS to "yes".
+-DISABLE_NLS=no
++DISABLE_NLS=yes
+ # Different optimizations for different cpus.
+ # Before gcc 2.8.0 only -m486