base-files: add basic procd integration, let procd start (and restart) ubus instead...
[openwrt.git] / package / ubus / Makefile
index 6bef8fe..782079d 100644 (file)
@@ -1,17 +1,22 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ubus
-PKG_VERSION:=2012-05-05
+PKG_VERSION:=2012-12-15
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/luci2/ubus.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=25b9b4b827f74482743689386b195dca3b81a0df
+PKG_SOURCE_VERSION:=bb856ad8a9a1e786494d01e34bbfe2b4d2134021
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
-PKG_MIRROR_MD5SUM:=d68885340ab1cee2e04e9055186beb11
+PKG_MIRROR_MD5SUM:=fe419893677d12e6455bbe5e3b503944
 CMAKE_INSTALL:=1
 
+PKG_LICENSE:=LGPLv2.1
+PKG_LICENSE_FILES:=
+
+PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
+
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/cmake.mk
 
@@ -28,6 +33,7 @@ define Package/ubusd
   CATEGORY:=LuCI2
   SUBMENU:=System
   TITLE:=OpenWrt RPC daemon
+  DEPENDS:=+libubox
 endef
 
 define Package/libubus
@@ -48,14 +54,16 @@ endef
 
 TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
 
+CMAKE_OPTIONS = \
+       -DLUAPATH=/usr/lib/lua
+
 define Package/ubus/install
        $(INSTALL_DIR) $(1)/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/ubus $(1)/bin/
 endef
 
 define Package/ubusd/install
-       $(INSTALL_DIR) $(1)/sbin $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/ubus.init $(1)/etc/init.d/ubus
+       $(INSTALL_DIR) $(1)/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/ubusd $(1)/sbin/
 endef