lantiq: Tune the XWAY subtarget cflags
[openwrt.git] / package / lua / patches / 100-no_readline.patch
index 7969a29..0350e47 100644 (file)
@@ -1,8 +1,6 @@
-Index: lua-5.1.3/src/luaconf.h
-===================================================================
---- lua-5.1.3.orig/src/luaconf.h       2008-04-13 16:18:00.338123105 +0200
-+++ lua-5.1.3/src/luaconf.h    2008-04-13 16:18:14.110907972 +0200
-@@ -36,7 +36,6 @@
+--- a/src/luaconf.h
++++ b/src/luaconf.h
+@@ -38,7 +38,6 @@
  #if defined(LUA_USE_LINUX)
  #define LUA_USE_POSIX
  #define LUA_USE_DLOPEN                /* needs an extra library: -ldl */
@@ -10,11 +8,9 @@ Index: lua-5.1.3/src/luaconf.h
  #endif
  
  #if defined(LUA_USE_MACOSX)
-Index: lua-5.1.3/src/Makefile
-===================================================================
---- lua-5.1.3.orig/src/Makefile        2008-04-13 16:18:18.695169214 +0200
-+++ lua-5.1.3/src/Makefile     2008-04-13 16:24:41.036957630 +0200
-@@ -17,6 +17,7 @@
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -17,6 +17,7 @@ LIBS= -lm $(MYLIBS)
  MYCFLAGS=
  MYLDFLAGS=
  MYLIBS=
@@ -22,7 +18,7 @@ Index: lua-5.1.3/src/Makefile
  
  # == END OF USER SETTINGS. NO NEED TO CHANGE ANYTHING BELOW THIS LINE =========
  
-@@ -83,7 +84,7 @@
+@@ -86,7 +87,7 @@ echo:
        @echo "MYLIBS = $(MYLIBS)"
  
  # convenience targets for popular platforms
@@ -31,7 +27,7 @@ Index: lua-5.1.3/src/Makefile
  none:
        @echo "Please choose a platform:"
        @echo "   $(PLATS)"
-@@ -98,16 +99,16 @@
+@@ -101,16 +102,16 @@ bsd:
        $(MAKE) all MYCFLAGS="-DLUA_USE_POSIX -DLUA_USE_DLOPEN" MYLIBS="-Wl,-E"
  
  freebsd: