lantiq: Tune the XWAY subtarget cflags
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 21 Jun 2013 16:54:15 +0000 (16:54 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 21 Jun 2013 16:54:15 +0000 (16:54 +0000)
This patch sets the cflags -mtune=34kc -mdsp only in XWAY subtarget, while the others remain with mtune=mips32r2.
Although the Danube has a Mips 24KEc core performs well with the above cflags.

Signed-off-by: José Vázquez Fernández <ppvazquezfer@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37006 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/lantiq/Makefile
target/linux/lantiq/ase/target.mk
target/linux/lantiq/falcon/target.mk
target/linux/lantiq/svip_be/target.mk
target/linux/lantiq/svip_le/target.mk
target/linux/lantiq/xway/target.mk

index d8c12ed..25fea54 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS=xway ase falcon
 
 LINUX_VERSION:=3.8.13
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
+CFLAGS=-Os -pipe -mips32r2 -fno-caller-saves -mno-branch-likely
 
 define Target/Description
        Build firmware images for Lantiq SoC
index a052dd2..f1f0c07 100644 (file)
@@ -2,6 +2,7 @@ ARCH:=mips
 SUBTARGET:=ase
 BOARDNAME:=Amazon-SE
 FEATURES:=squashfs atm
+CFLAGS+= -mtune=mips32r2
 
 DEFAULT_PACKAGES+=kmod-pppoa ppp-mod-pppoa linux-atm atm-tools br2684ctl kmod-ltq-dsl-ase ltq-dsl-app
 
index 14ac402..b7af20c 100644 (file)
@@ -3,6 +3,7 @@ SUBTARGET:=falcon
 BOARDNAME:=Falcon
 FEATURES:=squashfs
 DEVICE_TYPE:=other
+CFLAGS+= -mtune=mips32r2
 
 DEFAULT_PACKAGES+= kmod-ifxos gpon-base-files kmod-leds-gpio kmod-ledtrig-heartbeat \
        kmod-gpon-optic-drv gpon-optic-drv kmod-gpon-onu-drv gpon-onu-drv \
index 7cdd540..ef8eeff 100644 (file)
@@ -3,6 +3,7 @@ SUBTARGET:=svip_be
 BOARDNAME:=SVIP Big Endian
 FEATURES:=squashfs
 DEVICE_TYPE:=other
+CFLAGS+= -mtune=mips32r2
 
 DEFAULT_PACKAGES+= uboot-svip hostapd-mini
 
index 2c1ed07..d2ccdbc 100644 (file)
@@ -3,6 +3,7 @@ SUBTARGET:=svip_le
 BOARDNAME:=SVIP Little Endian
 FEATURES:=squashfs
 DEVICE_TYPE:=other
+CFLAGS+= -mtune=mips32r2
 
 DEFAULT_PACKAGES+= uboot-svip hostapd-mini
 
index 540de14..ffbc4ea 100644 (file)
@@ -2,6 +2,7 @@ ARCH:=mips
 SUBTARGET:=xway
 BOARDNAME:=XWAY
 FEATURES:=squashfs atm mips16
+CFLAGS+= -mtune=34kc -mdsp
 
 DEFAULT_PACKAGES+=kmod-leds-gpio kmod-gpio-button-hotplug