[packages/kernel] Make mv_cesa crypto module available on Orion as well.
[openwrt.git] / package / kernel / modules / crypto.mk
index 9227deb..49c5684 100644 (file)
@@ -22,9 +22,9 @@ SHA256_SUFFIX:=$(CRYPTO_GENERIC)
 SHA512_SUFFIX:=$(CRYPTO_GENERIC)
 
 CRYPTO_MODULES = \
-       ALGAPI=crypto_algapi \
+       $(if $(filter 1,$(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.28)),ALGAPI2,ALGAPI)=crypto_algapi \
        AEAD2=aead \
-       PCOMP=pcompress \
+       $(if $(filter 1,$(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.36)),PCOMP2,PCOMP)=pcompress \
        BLKCIPHER2=crypto_blkcipher \
        HASH2=crypto_hash \
        MANAGER2=cryptomgr \
@@ -41,7 +41,11 @@ crypto_name=$(if $(findstring y,$($(call crypto_confvar,$(1)))),,$(word 2,$(subs
 define KernelPackage/crypto-core
   SUBMENU:=$(CRYPTO_MENU)
   TITLE:=Core CryptoAPI modules
-  KCONFIG:=CONFIG_CRYPTO=y CONFIG_CRYPTO_HMAC $(foreach mod,$(CRYPTO_MODULES),$(call crypto_confvar,$(mod)))
+  KCONFIG:= \
+       CONFIG_CRYPTO=y \
+       CONFIG_CRYPTO_HW=y \
+       CONFIG_CRYPTO_HMAC \
+       $(foreach mod,$(CRYPTO_MODULES),$(call crypto_confvar,$(mod)))
   FILES:=$(foreach mod,$(CRYPTO_MODULES),$(call crypto_file,$(mod)))
   AUTOLOAD:=$(call AutoLoad,01,$(foreach mod,$(CRYPTO_MODULES),$(call crypto_name,$(mod))))
 endef
@@ -64,7 +68,6 @@ define KernelPackage/crypto-hw-padlock
   TITLE:=VIA PadLock ACE with AES/SHA hw crypto module
   DEPENDS:=+kmod-crypto-aes
   KCONFIG:= \
-       CONFIG_CRYPTO_HW=y \
        CONFIG_CRYPTO_DEV_PADLOCK \
        CONFIG_CRYPTO_DEV_PADLOCK_AES \
        CONFIG_CRYPTO_DEV_PADLOCK_SHA
@@ -81,7 +84,6 @@ $(eval $(call KernelPackage,crypto-hw-padlock))
 define KernelPackage/crypto-hw-geode
   TITLE:=AMD Geode hardware crypto module
   KCONFIG:= \
-       CONFIG_CRYPTO_HW=y \
        CONFIG_CRYPTO_DEV_GEODE
   FILES:=$(LINUX_DIR)/drivers/crypto/geode-aes.ko
   AUTOLOAD:=$(call AutoLoad,09,geode-aes)
@@ -95,7 +97,6 @@ define KernelPackage/crypto-hw-hifn-795x
   TITLE:=HIFN 795x crypto accelerator
   DEPENDS:=@!TARGET_ubicom32
   KCONFIG:= \
-       CONFIG_CRYPTO_HW=y \
        CONFIG_HW_RANDOM=y \
        CONFIG_CRYPTO_DEV_HIFN_795X \
        CONFIG_CRYPTO_DEV_HIFN_795X_RNG=y
@@ -111,7 +112,6 @@ define KernelPackage/crypto-hw-ixp4xx
   TITLE:=Intel IXP4xx hardware crypto module
   DEPENDS:=@TARGET_ixp4xx
   KCONFIG:= \
-       CONFIG_CRYPTO_HW=y \
        CONFIG_CRYPTO_DEV_IXP4XX
   FILES:=$(LINUX_DIR)/drivers/crypto/ixp4xx_crypto.ko
   AUTOLOAD:=$(call AutoLoad,90,ixp4xx_crypto)
@@ -129,7 +129,6 @@ define KernelPackage/crypto-hw-ppc4xx
   TITLE:=AMCC PPC4xx hardware crypto module
   DEPENDS:=@TARGET_ppc40x||TARGET_ppc44x
   KCONFIG:= \
-       CONFIG_CRYPTO_HW=y \
        CONFIG_CRYPTO_DEV_PPC4XX
   FILES:=$(LINUX_DIR)/drivers/crypto/amcc/crypto4xx.ko
   AUTOLOAD:=$(call AutoLoad,90,crypto4xx)
@@ -374,3 +373,14 @@ define KernelPackage/crypto-xts
 endef
 
 $(eval $(call KernelPackage,crypto-xts))
+
+define KernelPackage/crypto-mv_cesa
+   TITLE:=Marvell crypto engine
+   KCONFIG:=CONFIG_CRYPTO_DEV_MV_CESA
+   FILES:=$(LINUX_DIR)/drivers/crypto/mv_cesa.ko
+   AUTOLOAD:=$(call AutoLoad,09,mv_cesa)
+   SUBMENU:=Cryptographic API modules
+   DEPENDS:=kmod-crypto-core @TARGET_kirkwood||TARGET_orion
+endef
+
+$(eval $(call KernelPackage,crypto-mv_cesa))