[packages/kernel] Make mv_cesa crypto module available on Orion as well.
[openwrt.git] / package / kernel / modules / crypto.mk
index 27cbf47..49c5684 100644 (file)
@@ -373,3 +373,14 @@ define KernelPackage/crypto-xts
 endef
 
 $(eval $(call KernelPackage,crypto-xts))
+
+define KernelPackage/crypto-mv_cesa
+   TITLE:=Marvell crypto engine
+   KCONFIG:=CONFIG_CRYPTO_DEV_MV_CESA
+   FILES:=$(LINUX_DIR)/drivers/crypto/mv_cesa.ko
+   AUTOLOAD:=$(call AutoLoad,09,mv_cesa)
+   SUBMENU:=Cryptographic API modules
+   DEPENDS:=kmod-crypto-core @TARGET_kirkwood||TARGET_orion
+endef
+
+$(eval $(call KernelPackage,crypto-mv_cesa))