add 6tunnel package (thanks to Florian Fainelli)
[openwrt.git] / openwrt / package / Makefile
index 0c4d048..f46f13b 100644 (file)
@@ -3,6 +3,7 @@ include $(TOPDIR)/rules.mk
 
 package-:=tcp_wrappers
 package-y:=nvram
+package-$(BR2_PACKAGE_6TUNNEL) += 6tunnel
 package-$(BR2_PACKAGE_AICCU) += aiccu
 package-$(BR2_PACKAGE_AMWALL) += amwall
 package-$(BR2_PACKAGE_ARPD) += arpd
@@ -152,6 +153,7 @@ package-$(BR2_COMPILE_RP_PPPOE) += rp-pppoe
 package-$(BR2_PACKAGE_RRDCOLLECT) += rrdcollect
 package-$(BR2_COMPILE_RRDTOOL) += rrdtool
 package-$(BR2_COMPILE_RRDTOOL1) += rrdtool1
+package-$(BR2_COMPILE_RRS) += rrs
 package-$(BR2_PACKAGE_RSYNC) += rsync
 package-$(BR2_PACKAGE_SABLEVM) += sablevm
 package-$(BR2_PACKAGE_SABLEVM_CLASSPATH) += sablevm-classpath
@@ -378,6 +380,11 @@ ifneq ($(BR2_PACKAGE_PMACCT_PGSQL),)
 pmacct-compile: postgresql-compile
 endif
 
+rrs-compile: uclibc++-compile
+ifneq ($(BR2_PACKAGE_RRS),)
+rrs-compile: openssl-compile
+endif
+
 snort-compile: libnet-compile libpcap-compile pcre-compile
 ifeq ($(BR2_PACKAGE_SNORT_MYSQL),y)
 snort-compile: mysql-compile