Incorrect checkout of git submodules
[openwrt.git] / include / download.mk
index 372db03..1c3f23e 100644 (file)
@@ -88,7 +88,7 @@ define DownloadMethod/git
                rm -rf $(SUBDIR) && \
                [ \! -d $(SUBDIR) ] && \
                git clone $(URL) $(SUBDIR) --recursive && \
                rm -rf $(SUBDIR) && \
                [ \! -d $(SUBDIR) ] && \
                git clone $(URL) $(SUBDIR) --recursive && \
-               (cd $(SUBDIR) && git checkout $(VERSION)) && \
+               (cd $(SUBDIR) && git checkout $(VERSION) && git submodule update) && \
                echo "Packing checkout..." && \
                rm -rf $(SUBDIR)/.git && \
                $(call dl_pack,$(TMP_DIR)/dl/$(FILE),$(SUBDIR)) && \
                echo "Packing checkout..." && \
                rm -rf $(SUBDIR)/.git && \
                $(call dl_pack,$(TMP_DIR)/dl/$(FILE),$(SUBDIR)) && \