Incorrect checkout of git submodules
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 10 Oct 2013 15:01:50 +0000 (15:01 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 10 Oct 2013 15:01:50 +0000 (15:01 +0000)
When checking out git packages, buildroot doesn't seem to track the revisions
correctly of any submodules referenced by that project. As a result, the
submodule stays at whatever revision was referenced by the head of the master
branch. Running a 'git submodule update' after the checkout fixes this problem.

Signed-off-by: Owen Kirby <osk@exegin.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38359 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/download.mk

index 372db03..1c3f23e 100644 (file)
@@ -88,7 +88,7 @@ define DownloadMethod/git
                rm -rf $(SUBDIR) && \
                [ \! -d $(SUBDIR) ] && \
                git clone $(URL) $(SUBDIR) --recursive && \
-               (cd $(SUBDIR) && git checkout $(VERSION)) && \
+               (cd $(SUBDIR) && git checkout $(VERSION) && git submodule update) && \
                echo "Packing checkout..." && \
                rm -rf $(SUBDIR)/.git && \
                $(call dl_pack,$(TMP_DIR)/dl/$(FILE),$(SUBDIR)) && \