mac80211: make rt2x00_soc depend on !rt3883
authorJohn Crispin <blogic@openwrt.org>
Thu, 4 Jul 2013 13:31:18 +0000 (13:31 +0000)
committerJohn Crispin <blogic@openwrt.org>
Thu, 4 Jul 2013 13:31:18 +0000 (13:31 +0000)
https://dev.openwrt.org/ticket/13777

Signed-off-by: John Crispin <blogic@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37162 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/mac80211/Makefile

index ef10eca..9b2f54d 100644 (file)
@@ -256,7 +256,7 @@ endef
 
 define KernelPackage/rt2x00-soc
 $(call KernelPackage/rt2x00/Default)
-  DEPENDS+= @TARGET_ramips @!TARGET_ramips_mt7620a +kmod-rt2x00-mmio +kmod-rt2x00-lib
+  DEPENDS+= @TARGET_ramips @!TARGET_ramips_mt7620a @!TARGET_ramips_rt3883 +kmod-rt2x00-mmio +kmod-rt2x00-lib
   TITLE+= (SoC)
   FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/rt2x00/rt2x00soc.ko
   AUTOLOAD:=$(call AutoLoad,26,rt2x00soc)