brcm63xx: hcsimage: respect load address
authorJonas Gorski <jogo@openwrt.org>
Wed, 25 Mar 2015 15:34:45 +0000 (15:34 +0000)
committerJonas Gorski <jogo@openwrt.org>
Wed, 25 Mar 2015 15:34:45 +0000 (15:34 +0000)
Respect the vmlinux load address when generating images.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44983 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/brcm63xx/image/Makefile

index 1913feb..47756bf 100755 (executable)
@@ -119,7 +119,8 @@ define Image/Build/HCSDTB
        # Generate the image
        $(STAGING_DIR_HOST)/bin/hcsmakeimage --magic_byte=$(4) \
                --rev_maj=$(5) --rev_min=$(6) --input_file=$(KDIR)/$(7) \
-               --output_file=$(BIN_DIR)/openwrt-$(2)-$(1).bin
+               --output_file=$(BIN_DIR)/openwrt-$(2)-$(1).bin \
+               --ldaddress=$(LOADADDR)
 endef
 
 define Image/Build/ChkDTB